SPF
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 5103 | Accepted: 2347 |
Description
Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.
Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.
Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.
Input
The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output
For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.
The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input
1 2 5 4 3 1 3 2 3 4 3 5 0 1 2 2 3 3 4 4 5 5 1 0 1 2 2 3 3 4 4 6 6 3 2 5 5 1 0 0
Sample Output
Network #1 SPF node 3 leaves 2 subnets Network #2 No SPF nodes Network #3 SPF node 2 leaves 2 subnets SPF node 3 leaves 2 subnets
Source
题意,就是去掉一个点和这个点连的边,图就不连通的点,其实,这个点,就是割点 关节点 。
使用tarjan算法,如果,满足dfn[v]<=low[u],那么v就是一个割点,
割点要满足两个条件,
1.如果顶点u是深度优先搜索生成树的根,则u至少有两个子女。(如果,只有1个,去掉这个点,子树就断开了)
2.如果u不是生成树的根,则它至少有一个子女 满足dfn[v]<=low[u],
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define N 1050
#define E 105000
int head[N],next[E],vec[E],edge_m,n,dfn[N],low[N],clock,vis[N],son,re[N];
int addedge(int a,int b){
vec[edge_m]=b;next[edge_m]=head[a];head[a]=edge_m++;
vec[edge_m]=a;next[edge_m]=head[b];head[b]=edge_m++;
}
void init(){
memset(head,-1,sizeof(head));
memset(vis,0,sizeof(vis));
memset(re,0,sizeof(re));
son=0;
edge_m=0;n=-1;clock=0;
}
int tarjan(int x){
dfn[x]=low[x]=clock++;
vis[x]=1;
int i,goal;
for(i=head[x];i!=-1;i=next[i]){
goal=vec[i];
if(!vis[goal]){
tarjan(goal);
low[x]=min(low[x],low[goal]);
if(dfn[x]<=low[goal]){
if(x==1){son++;}
else {
re[x]++;
}
}
}
else {
low[x]=min(low[x],dfn[goal]);
}
}
return 1;
}
int main()
{
int s,e,tt=1;
while(scanf("%d",&s)&&s){
init();
printf("Network #%d\n",tt++);
scanf("%d",&e);
n=max(n,s);n=max(n,e);
addedge(s,e);
while(scanf("%d",&s)&&s){
scanf("%d",&e);
n=max(n,s);n=max(n,e);
addedge(s,e);
}
tarjan(1);
if(son>1)re[1]=son-1;
bool flag=true;
for(int i=1;i<=n;i++){
if(re[i]>0){
flag=false;
printf(" SPF node %d leaves %d subnets\n",i,re[i]+1);
}
}
if(flag){
printf(" No SPF nodes\n");
}
printf("\n");
}
return 0;
}