hdu2999 Stone Game, Why are you always there?

67 篇文章 1 订阅

Stone Game, Why are you always there?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 353 Accepted Submission(s): 117


Problem Description
“Alice and Bob are playing stone game...”
“Err.... Feel bored about the stone game? Don’t be so, because stone game changes all the time!”
“What the hell are they thinking for?”
“You know, whenever Alice is trying to make fun of Bob, she asked him to play stone game with him.”
“Poor Bob... What’s the rule today?”
“It seems Alice only allows some fixed numbers of continuous stones can be taken each time. And they begin with one string of stones.”
“A string? Formed as a circle or a line?”
“A line.”
“Well, I think I may help Bob with that.”
“How?”
“I may tell him to skip this round if he has no chance to win.”
“Good idea maybe, I mean, Alice always let Bob play first, because she think herself is smart enough to beat Bob no matter how.”
“Yes, she’s actually right about herself. Let me see if Bob has a chance to win...”
......

Input
There are multiple test cases, for each test case:
The first line has a positive integer N (1<=N<=100).
The second line contains N positive integers, a1, a2 ... an, separated by spaces, which indicate the fixed numbers Alice gives.
The third line, a positive integer M. (M<=1000)
Following M lines, one positive integer K (K<=1000) each line. K means in this round, the length of the stone string.

Output
For each K, output “1” if Bob has a chance to win, output “2” if Bob has no chance, or “0” if it’s undeterminable.

Sample Input
  
  
3 1 5 1 1 1

Sample Output
  
  
1
直接求出sg函数值来就可以了!
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define M 10050
int pri[M],a[M],cnt;
int getsg(int n){
    if(pri[n]!=-1)return pri[n];
    int vis[M];
    mem(vis,0);
    for(int i=0;i<cnt&&a[i]<=n;i++){
        for(int j=0;j<=n-a[i];j++){
            if(pri[j]==-1)pri[j]=getsg(j);
            if(pri[n-j-a[i]]==-1)pri[n-j-a[i]]=getsg(n-j-a[i]);
            vis[pri[j]^pri[n-j-a[i]]]=1;
        }
    }
    for(int i=0;;i++)
    if(!vis[i])
    return i;
}
int main()
{
    int n,i,k,x;
    while(scanf("%d",&n)!=EOF){
        mem(pri,-1);
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        sort(a,a+n);
        for(i=1,cnt=0;i<n;i++){
            if(a[i]!=a[cnt])a[++cnt]=a[i];
        }
        cnt++;
        scanf("%d",&k);
        for(i=0;i<k;i++){
            scanf("%d",&x);
            if(getsg(x))printf("1\n");
            else printf("2\n");
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值