hdu2795 解题报告 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6782    Accepted Submission(s): 3069


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
还是线段树,很水的题,其实,用线段树来优化时间,用L[]来记区间的最大值,查询一下,返回第几行,也就是L的值 ,就可以了,当然,这题有个坑,就是10的9次方,其实,建这么大的树是不可能的,想一想,就是用N的值就可以了,因为,H就是能用的最大值,如果H>n,那么大的部分,根本就是用不着的!因为,一个只占一行啊!最高也就要N就可以了!也就是H最大200000!
#include <iostream>
#include <stdio.h>
using namespace std;
int h,w,n;
#define N 500000
int l[N<<2];
int maxx (int a,int b)
{
      if(a<b)
            return b;
      else
            return a;
}
void build(int num,int s,int e)
{

      if(s==e)
      {
            l[num]=w;

            return ;
      }

      int mid=(s+e)>>1;

      build(num<<1,s,mid);
      build(num<<1|1,mid+1,e);
      l[num]=maxx(l[num<<1],l[num<<1|1]);

}
int query(int num ,int s, int e,int a)
{
      if(s==e)
      {

                  l[num]=l[num]-a;
                  return s;

      }
      int mid=(s+e)>>1;
      int re=l[num<<1]>=a ? query(num<<1,s,mid,a):query(num<<1|1,mid+1,e,a);
      l[num]=maxx(l[num<<1],l[num<<1|1]);
      return re;
}
int main()
{
  int a;
  while(scanf("%d%d%d",&h,&w,&n)!=EOF)
  {
        if (h > 200000) h = 200000;
        build(1,1,h);
        while(n--)
        {
              scanf("%d",&a);
              if(l[1]>=a)
                  printf("%d\n",query(1,1,h,a));
              else
                  printf("-1\n");
        }


  }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值