poj1328

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42242 Accepted: 9359

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
水题!贪心的思想
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
struct pti{
double x,y,min,max;
} num[1050],temp;
#define eps 1e-10
bool cmp(pti a,pti b)
{
	if(b.min-a.min>=eps)
		return true;
	return false;
}
int main ()
{
	int i,n,j,sum,flag=1,re;
	double min,max,te,r;
	while(scanf("%d%lf",&n,&r)!=EOF&&n&&r)
	{
		if(r<=0)
			re=0;
		else
			re=1;
		for(i=1;i<=n;i++)
		{
			scanf("%lf%lf",&num[i].x,&num[i].y);
		
			if(((r>=num[i].y))&&re)
			{
				te=r*r-num[i].y*num[i].y;
				num[i].min=num[i].x-sqrt(te);
				num[i].max=num[i].x+sqrt(te);
			}
			else
			{
				re=0;
			}
		}
		if(re)
		{
			sort(num+1,num+n+1,cmp);
			/*for(i=1;i<=n;i++)
				printf("%lf ",num[i].min);
				*/
		sum=1;
		min=num[1].min;
		max=num[1].max;

		for(i=2;i<=n;i++)
		{
			if(max-num[i].min>=eps)
			{
			
				if(max-num[i].max>=eps)
					max=num[i].max;

			}
			else
			{
				sum++;
				min=num[i].min;
				max=num[i].max;
			}

		}
		printf("Case %d: %d\n",flag++,sum);
		}
		else
		{
			sum=-1;
			printf("Case %d: %d\n",flag++,sum);
		}


	}


	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值