UVA 568 (13.07.28)

 Just the Facts 

The expression N!, read as `` N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the lastnon-zero digit of anyfactorial for ($0 \le N \le 10000$). For example, if your program is asked tocompute the last nonzerodigit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000,each on its own linewith no other letters, digits or spaces. For each integer N, you shouldread the value and compute the last nonzero digit of N!.

Output 

For each integer input, the program should print exactly one line ofoutput. Each line of outputshould contain the value N, right-justified in columns 1 through 5 withleading blanks, not leadingzeroes. Columns 6 - 9 must contain `` -> " (space hyphen greater space).Column 10 must contain the single last non-zero digit of N!.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8


题意:

给出N, 求N的阶乘的最后一位是什么, 除零以外


思路:

考虑到零都是由2*5得来的, 那么每一次阶乘的时候, 把要乘的数对2和5去判断是否整除, 并统计整除2和5的次数分别是多少

最后我们再看看对2和5整除的次数分别是多少, 哪个多就还原哪个, 还原到对2对5的整除次数一致为止, 保证了2*5=10的成对性


AC代码如下:

#include<stdio.h>

int main() {
	int N;
	int ans, t, num2, num5;
	while(scanf("%d", &N) != EOF) {
		ans = 1;
		num2 = num5 = 0;
		for(int i = N; i > 1; i--) {
			t = i;
			while(t % 2 == 0) {
				num2++;
				t = t / 2;
			}
			while(t % 5 == 0) {
				num5++;
				t = t / 5;
			}
			ans = ans * t;
			ans = ans % 10;
		}
		if(num2 > num5) {
			while(num2 > num5) {
				ans = ans * 2;
				ans = ans % 10;
				num2--;
			}
		}
		if(num5 > num2) {
			while(num5 > num2) {
				ans = ans * 5;
				ans = ans % 10;
				num5--;
			}
		}
		printf("%5d -> %d\n", N, ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值