Just the Facts

Description

The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example, 
 N       N! 

 0       1 
 1       1 
 2       2 
 3       6 
 4      24 
 5     120 
10 3628800 

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for (0 <= N <= 10000). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.

Output

For each integer input, the program should print exactly one line of output. Each line of output should contain the value N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain " -> " (space hyphen greater space). Column 10 must contain the single last non-zero digit of N!.

Sample Input

1
2
26
125
3125
9999

Sample Output

 1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8

解题思路:

出题人把它归为高精度,真是太坏了!千万别看到阶层就以为是高精度,给的数很吓人,让你求阶层后最右边不为0的数,不会真有人用高精度求了吧。。。。跟高精度八竿子打不着。后面的0乘以任何数都为0,所以不会影响我最后一个不为0的数,唯一担心的是进位问题,由于不会超过10000的阶层,也就是说每次乘的数不会超过10000,我只要每次保证最后一个数不为0,并且取最后4位去乘下一个数就行,无论它怎么进位都影响不到我输出正确答案了。

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int n, ans;
    while(scanf("%d", &n) != EOF)
    {
        ans = 1;
        for(int i = 1; i <= n; i++)
        {
            ans *= i;
            while(ans % 10 == 0)  // 去除末尾的0
                ans /= 10;
            ans %= 10000;  //取最后4位
        }
        printf("%5d -> %d\n", n, ans % 10);  //注意一下输出格式,我PE了一发
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值