【Python】字符串验证方法

一、题目

Python has built-in string validation methods for basic data, it can check if a string is composed of alphabetical characters, alphanumeric characters, digits, etc.

str.isalnum()

This method checks if all the characters of a string are alphanumeric (a-z, A-Z and 0-9).

>>> print 'ab123'.isalnum()

True

>>> print 'ab123#'.isalnum()

False

str.isalpha()

This method checks if all the characters of a string are alphabetical (a-z and A-Z).

>>> print 'abcD'.isalpha()

True

>>> print 'abcd1'.isalpha()

False

str.isdigit()

This method checks if all the characters of a string are digits (0-9).

>>> print '1234'.isdigit()

True

>>> print '123edsd'.isdigit()

False

str.islower()

This method checks if all the characters of a string are lowercase characters (a-z).

>>> print 'abcd123#'.islower()

True

>>> print 'Abcd123#'.islower()

False

str.isupper()

This method checks if all the characters of a string are uppercase characters (A-Z).

>>> print 'ABCD123#'.isupper()

True

>>> print 'Abcd123#'.isupper()

False

Task

You are given a string S.

Your task is to find out if the string S contains:  alphanumeric characters, alphabetical characters, digits, lowercase and uppercase characters.

Output Format

In the first line, print True if S has any alphanumeric characters. Otherwise, print False.
In the second line, print True if S has any alphabetical characters. Otherwise, print False.
In the third line, print True if S has any digits. Otherwise, print False.
In the fourth line, print True if S has any lowercase characters. Otherwise, print False.
In the fifth line, print True if S has any uppercase characters. Otherwise, print False.

Sample Input

qA2

Sample Output

True
True
True
True
True

二、代码

if __name__=='__main__':
    s = input()
    
    has_alphanumeric = any(c.isalnum() for c in s)

    has_alpha = any(c.isalpha() for c in s)

    has_digits = any(c.isdigit() for c in s)

    has_lowercase = any(c.islower() for c in s)

    has_uppercase = any(c.isupper() for c in s)

    print(has_alphanumeric)
    print(has_alpha)
    print(has_digits)
    print(has_lowercase)
    print(has_uppercase)

  • 11
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值