[PAT (Advanced Level) ]1014.Waiting in Line 解题文档

1014. Waiting in Line (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: 

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am. 

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

分析:采用队列实现。效果还可以,但是算法效率还是不够好。

//本题容易出错的地方:是在17:00及以后开始服务的客户输出"Sorry",而不是17:00之前结束服务的输出"Sorry"

//如客户cId16:59开始服务,服务时间为2,则输出的应该是17:01,而不是"Sorry"

//例子:

//

/*

input

2 2 7 5

1 2 6 4 3 535 2

3 4 5 6 7

output

 08:07

 08:06

 08:10

 17:01

 Sorry

 */


C++代码如下。


//本题容易出错的地方:是在17:00及以后开始服务的客户输出"Sorry",而不是17:00之前结束服务的输出"Sorry";
//如客户cId是16:59开始服务,服务时间为2,则输出的应该是17:01,而不是"Sorry"。
//例子:
//
/*
input
2 2 7 5
1 2 6 4 3 535 2
3 4 5 6 7
output
 08:07
 08:06
 08:10
 17:01
 Sorry
 */
#include<iostream>
#include<vector>
#include<queue>
using namespace std;

int main(){
    int N,M,K,Q;
    queue<int> queuetime;
    vector<int> vectime;
    vector<int> person;
    int time[1000]={0};
    cin>>N>>M>>K>>Q;
    person.resize(Q);
    for(int i=0;i<K;i++){
        int temp;
        cin>>temp;
        queuetime.push(temp);
        vectime.push_back(temp);
    }
    for(int i=0;i<Q;i++){
        cin>>person[i];
    }
    int begintime=480;
    queue<int> Queue[1000];
    queue<int> QueueID[1000];
    bool flag=true;
    bool flagMFull=false;
    int flagNum=0;
    if(M==0||N==0){
        for(int i=0;i<K;i++){
            cout<<"Sorry"<<endl;
        }
        return 0;
    }
    while(flag)
    {
        //find a short line
        while(!queuetime.empty()&&!flagMFull){
            int shortlineId=0;
            int shortlineNum=(int)Queue[0].size();
            for(int i=1;i<N;i++){
                if(shortlineNum>Queue[i].size()){
                    shortlineNum=(int)Queue[i].size();
                    shortlineId=i;
                }
            }
            if(shortlineNum==M){
                flagMFull=true;
                break;//full
            }
            Queue[shortlineId].push(queuetime.front());
            QueueID[shortlineId].push(flagNum++);
            queuetime.pop();
        }
        
        //delete
        int mintime=99999999;
        int mintimeNum=-1;
        for(int i=0;i<N;i++){
            if(!Queue[i].empty()){
                if(mintime>Queue[i].front()){
                    mintime=Queue[i].front();
                    mintimeNum=i;
                }
            }
        }
        // cout<<"length"<<Queue[mintimeNum].size()<<endl;
        
        Queue[mintimeNum].pop();
        flagMFull=false;
        begintime+=mintime;
        time[QueueID[mintimeNum].front()]=begintime;
        QueueID[mintimeNum].pop();
        for(int i=0;i<N;i++){
            if(i!=mintimeNum){
                Queue[i].front()-=mintime;
            }
        }
        // cout<<"No:"<<mintimeNum+1<<"   mintime:"<<mintime<<"  front:"<<Queue[mintimeNum].size()<<endl;
        
        //break;
        flag=false;
        if(!queuetime.empty()){
            flag=true;
        }
        for(int i=0;i<N;i++){
            if(!Queue[i].empty()){
                flag=true;
                break;
            }
        }
    }
    
    for(int i=0;i<Q;i++){
        int time1,time2;
        if(time[person[i]-1]-vectime[person[i]-1]>=1020)
            cout<<"Sorry"<<endl;
        else{
           // time[person[i]-1]+=vectime[person[i]-1];
            time1=time[person[i]-1]/60;
            time2=time[person[i]-1]%60;
            if(time1<10)
                cout<<"0"<<time1<<":";
            else
                cout<<time1<<":";
            if(time2<10)
                cout<<"0"<<time2<<endl;
            else
                cout<<time2<<endl;
            }
    }
        
    return 0;
}



所有测试点均通过。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值