POJ 3678 Katu Puzzle

题目链接 : POJ3678

Katu Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6427 Accepted: 2346

Description

Katu Puzzle is presented as a directed graph G(V, E) with each edge e(a, b) labeled by a boolean operator op (one of AND, OR, XOR) and an integer c (0 ≤ c ≤ 1). One Katu is solvable if one can find each vertex Vi a value Xi (0 ≤ Xi ≤ 1) such that for each edge e(a, b) labeled by op and c, the following formula holds:

 Xa op Xb = c

The calculating rules are:

AND01
000
101
OR01
001
111
XOR01
001
110

Given a Katu Puzzle, your task is to determine whether it is solvable.

Input

The first line contains two integers N (1 ≤ N ≤ 1000) and M,(0 ≤ M ≤ 1,000,000) indicating the number of vertices and edges.
The following M lines contain three integers a (0 ≤ a < N), b(0 ≤ b < N), c and an operator op each, describing the edges.

Output

Output a line containing "YES" or "NO".

Sample Input

4 4
0 1 1 AND
1 2 1 OR
3 2 0 AND
3 0 0 XOR

Sample Output

YES

Hint

X 0 = 1, X 1 = 1, X 2 = 0, X 3 = 1.

Source

 

 

2-SAT 入门题

建图细节以后写~

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
#include<queue>
using namespace std;


vector<int> gra[2005];
bool vis[2005];
int stack[2005],k;
int low[2005],dfn[2005],scc[2005];
int timer,cnt;
void tarjan_scc(int s)
{
	vis[s]=1;
	low[s]=dfn[s]=++timer;
	stack[k++]=s;
	int to;
	for(int i=0;i<gra[s].size();i++)
	{
		to=gra[s][i];
		if(dfn[to]==0) 
        {
            tarjan_scc(to);
            low[s]=min(low[to],low[s]);
        }
        else if(vis[to]) low[s]=min(dfn[to],low[s]);
	}
	if(dfn[s]==low[s])
	{
		do
		{
			to=stack[--k];
			vis[to]=0;
			scc[to]=cnt;
		}while(stack[k]!=s);
		cnt++;
	}
}
int main()
{
//	freopen("1.txt","r",stdin);
	int n,m,a,b,c;
	char str[5];
	scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d%s",&a,&b,&c,str);
        a++;b++;
        if(str[0]=='A')
        {
            if(c) gra[a+n].push_back(a),gra[b+n].push_back(b);
            else gra[a].push_back(b+n),gra[b].push_back(a+n);
        }
        else if(str[0]=='X')
        {
            if(c) gra[a].push_back(b+n),gra[b].push_back(a+n),gra[a+n].push_back(b),gra[b+n].push_back(a);
            else gra[a+n].push_back(b+n),gra[b+n].push_back(a+n),gra[a].push_back(b),gra[b].push_back(a);
        }
        else
        {
            if(c) gra[a+n].push_back(b),gra[b+n].push_back(a);
            else gra[a].push_back(a+n),gra[b].push_back(b+n);
        }
    }
    cnt=1;timer=0;
    for(int i=0;i<n;i++)
        if(scc[i]==0 && scc[i+n]==0) tarjan_scc(i);
    bool flag=1;
    for(int i=0;i<n;i++)
        if(scc[i]==scc[i+n])
        {
            flag=0;
            break;
        }
    if(flag) printf("YES\n");
    else printf("NO\n");
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值