TOJ 10007 The last non-zero digit of n!

题目链接 :TOJ10007

10007 - The last non-zero digit of n!

Time Limit: 5000MS
Memory Limit: 65535KB

 

Description
Given an integer n, please output the last non-zero digit ofn!

For example, 5!=120, the last non-zero digit is 2, for 9!=362880 it is 8.


Input
One positive integer n. (0<n<1010001)


Output
The last non-zero digit of n!


Sample Input
1



Sample Output
1

 

 

经典题目

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
using namespace std;


int mod[20]={1,1,2,6,4,2,2,4,2,8,4,4,8,4,6,8,8,6,8,2};
char num[10005];
int a[10005];

int main()
{
    int len,t,c,i;
    while(scanf("%s",num)==1)
    {
        t=1;
        len=strlen(num);
        for(i=0;i<len;i++)
            a[i]=num[len-i-1]-'0';
        while(len)
        {
            len-=!a[len-1];
            t=t*mod[a[1]%2*10+a[0]]%10;
            for(c=0,i=len-1;i>-1;i--)
            {
                c=c*10+a[i];
                a[i]=c/5;
                c%=5;
            }
        }
        printf("%d\n",t);
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值