HDU 1711 Number Sequence

题目链接 : HDU1711

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7878    Accepted Submission(s): 3594


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 


 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 


 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 


 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 


 

Sample Output
  
  
6 -1
 


 

Source
 


 

Recommend
lcy
 

 

KMP模板题

也用扩展KMP做了一下

 

KMP  Ver.

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
using namespace std;




int str[1000005];
int nex[10005],ori[10005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int i,j;
        for(i=0;i<n;i++)
            scanf("%d",str+i);
        for(i=0;i<m;i++)
            scanf("%d",ori+i);
        i=0;j=-1;
        nex[0]=-1;
        while(i!=m)
        {
            while(j!=-1 && ori[i]!=ori[j]) j=nex[j];
            i++;j++;
            if(ori[j]==ori[i]) nex[i]=nex[j];
            else nex[i]=j;
        }
        i=0;j=0;
        int ans=-1;
        while(i!=n)
        {
            while(j!=-1 && str[i]!=ori[j] ) j=nex[j];
            i++;j++;
            if(j==m)
            {
                ans=i-m+1;
                break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


 

 

 

扩展KMP Ver.

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
using namespace std;


int str[1000005],ori[10005];
int extend[1000005],nex[10005];
int n,m;
void extend_kmp()
{
    int i,j=-1,l,r;
    for(i=1;i<m;i++,j--)
    {
        if(j<0 || i+nex[i-l]>=r)
        {
            if(j<0) j=0,r=i;
            while(r<m && ori[j]==ori[r]) r++,j++;
            nex[i]=j;l=i;
        }
        else nex[i]=nex[i-l];
    }
    nex[0]=i;j=-1;
    for(i=0;i<n;i++,j--)
    {
        if(j<0 || i+nex[i-l]>=r)
        {
            if(j<0) j=0,r=i;
            while(r<n && j<m && ori[j]==str[r]) r++,j++;
            extend[i]=j;l=i;
        }
        else extend[i]=nex[i-l];
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d",str+i);
        for(int i=0;i<m;i++)
            scanf("%d",ori+i);
        extend_kmp();
        int ans=-1;
        for(int i=0;i<n;i++)
            if(extend[i]>=m)
            {
                ans=i+1;
                break;
            }
        printf("%d\n",ans);
    }
    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值