PKU 1577 Falling Leaves

Description:
 Figure 1
Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem. A binary tree of letters may be one of two things:
  1. It may be empty.
  2. It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.
In the graphical representation of a binary tree of letters:
  1. Empty trees are omitted completely.
  2. Each node is indicated by
    • Its letter data,
    • A line segment down to the left to the left subtree, if the left subtree is nonempty,
    • A line segment down to the right to the right subtree, if the right subtree is nonempty.
A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y. The preorder traversal of a tree of letters satisfies the defining properties:
  1. If the tree is empty, then the preorder traversal is empty.
  2. If the tree is not empty, then the preorder traversal consists of the following, in order
    • The data from the root node,
    • The preorder traversal of the root's left subtree,
    • The preorder traversal of the root's right subtree.
The preorder traversal of the tree in Figure 1 is KGCBDHQMPY. A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies: The root's data comes later in the alphabet than all the data in the nodes in the left subtree. The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree. The problem: Consider the following sequence of operations on a binary search tree of letters Remove the leaves and list the data removed Repeat this procedure until the tree is empty Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree
by removing the leaves with data BDHPY CM GQ K Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.

输入说明

The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters. The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*'). The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.

输出说明

For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

输入样例

BDHPY
CM
GQ
K
*
AC
B
$

输出样例

KGCBDHQMPY
BAC
 
 
题解:
    二叉树的插入和读取,右对齐的,就是在找的时候比大小,比他大的就排在右边,直到右边有空位,比他小的就排在左边,直到左边有空位。
 
 
 
 
 
 
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
char sh[1000][1000];
int c;
typedef struct ER
{
	char bit;
	int l,r,p;
}ER;
ER er[10010];
void pai(int a,char b)
{
	int i,j,k,l,m,t,n;
	if(b>er[a].bit)
	{
		if(er[a].r==0)
		{
			er[a].r=++c;
			er[c].bit=b;
		}
		else pai(er[a].r,b);
	}
	else
	{
		if(er[a].l==0)
		{
			er[a].l=++c;
			er[c].bit=b;
		}
		else pai(er[a].l,b);
	}
}
void pri(int i)
{
	printf("%c",er[i].bit);
	if(er[i].l!=0)
		pri(er[i].l);
	if(er[i].r!=0)
		pri(er[i].r);
}
void qing()
{
	int i,j;
	for(i=0;i<1000;i++)
		sh[i][0]='\0';
}
int main()
{
	ER root,temp,nel,ner;
	int i,j,k,l,m,n,leni,ye,len;
	char a,b,c,d;
	while(1)
	{
		memset(er,0,sizeof(er));
		for(i=0;sh[i-1][0]!='*'&&sh[i-1][0]!='$';i++)
			scanf("%s",&sh[i]);
		leni=i-2;
		er[0].bit=sh[leni][0];
		c=0;
		for(i=leni-1;i>=0;i--)
			for(j=0;j<(len=strlen(sh[i]));j++)
		    {
			    pai(0,sh[i][j]);
		    }
		pri(0);
		printf("\n");
		if(sh[leni+1][0]=='$')
			break;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值