UVa490 Rotating Sentences


 Rotating Sentences 

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise.So instead of displaying the input sentences from left to right and top to bottom, your programwill display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding100 characters long. Legal characters include: newline, space, any punctuation characters, digits,and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmostcolumn; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"


这题大意就是将字符串反转90度输出,没有什么太好的方法,求出对于n行字符串,记录下其最长长度l作为其输出最大行数,输出则从第n行到第1行,从第1个字符到第l个字符输出,要注意的便是,当某些字符串的长度小于l时,要用空格补全。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;

const int N = 200;

int main() {
	char str[N][N];
	int t = 0;
	int len = 0;
	while (gets(str[t])) {
		int t_len = strlen(str[t]);
		len = max(len,t_len);
		t++;
	}
	for (int i = 0; i < len; i++) {
		for (int j = t-1; j >= 0; j--) {
			if (str[j][i])
				cout << str[j][i];
			else
				cout << ' ';
		}
		cout << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值