HDU 5937 Equation 【DFS+剪枝】 (2016年中国大学生程序设计竞赛(杭州))

67 篇文章 0 订阅
63 篇文章 0 订阅

Equation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 92    Accepted Submission(s): 24


Problem Description
Little Ruins is a studious boy, recently he learned addition operation! He was rewarded some number bricks of  1  to  9  and infinity bricks of addition mark  '+' and equal mark  '='.

Now little Ruins is puzzled by those bricks because he wants to put those bricks into as many different addition equations form  x+y=z  as possible. Each brick can be used at most once and x, y, z are one digit integer.

As Ruins is a beginer of addition operation,  x y  and  z  will be single digit number.

Two addition equations are different if any number of  x y  and  z  is different.

Please help little Ruins to calculate the  maximum number of different addition equations.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case contains one line with nine integers, the  ith  integer indicates the number of bricks of  i .

Limits
1T30
0bricks number of each type100
 

Output
For every test case, you should output  'Case #x: y', where  x indicates the case number and counts from  1 and  y is the result.
 

Sample Input
  
  
3 1 1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 2 2 0 3 3 0 3 0 0 0 0
 

Sample Output
  
  
Case #1: 2 Case #2: 6 Case #3: 2
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5960  5959  5958  5957  5956 
 

Statistic |  Submit |  Discuss |  Note

题目链接:

  http://acm.hdu.edu.cn/showproblem.php?pid=5937

题目大意:

  给1~9 9个数字,每个数字有Xi个,问总共能凑成多少个不同的等式A+B=C(A B C均为1位,1+2=3和2+1=3视为不同等式)

题目思路:

  【DFS+剪枝】

  这题本来想成网络流,建图建不出来最后只能靠爆搜+剪枝过了【我太弱了,第一名15ms过的。我234ms。可能有正解吧】

  首先列出等式总共就36种,每种数字最多需要17-i个,然后我就这样爆搜+剪枝T的死死的。

  后来经学长点拨说可以缩到20(视为有序,1+2=3和2+1=3视为同一种,乘上1或2)

  然后我又调整了下搜索的顺序,然后就。。过了。

  【程序里a是等式,b是三个数,c是能够用几次,d是前i个最多能组成多少等式】



//
//by coolxxx
//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<bitset>
#include<memory.h>
#include<time.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
//#include<stdbool.h>
#include<math.h>
#pragma comment(linker,"/STACK:1024000000,1024000000")
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
#define abs(a) ((a)>0?(a):(-(a)))
#define lowbit(a) (a&(-a))
#define sqr(a) ((a)*(a))
#define swap(a,b) ((a)^=(b),(b)^=(a),(a)^=(b))
#define mem(a,b) memset(a,b,sizeof(a))
#define eps (1e-8)
#define J 10000
#define mod 1000000007
#define MAX 0x7f7f7f7f
#define PI 3.14159265358979323
#define N 24
#define M 1004
using namespace std;
typedef long long LL;
double anss;
LL aans;
int cas,cass;
int n,m,lll,ans;
int num[10];
int a[N]={
	112,
	123,
	134,224,
	145,235,
	156,246,336,
	167,257,347,
	178,268,358,448,
	189,279,369,459};
int b[N][3]={
	{1,1,2},
	{1,2,3},
	{1,3,4},{2,2,4},
	{1,4,5},{2,3,5},
	{1,5,6},{2,4,6},{3,3,6},
	{1,6,7},{2,5,7},{3,4,7},
	{1,7,8},{2,6,8},{3,5,8},{4,4,8},
	{1,8,9},{2,7,9},{3,6,9},{4,5,9}};
int c[N]={
	1,
	2,
	2,1,
	2,2,
	2,2,1,
	2,2,2,
	2,2,2,1,
	2,2,2,2};
int d[N]={
	1,
	3,
	5,6,
	8,10,
	12,14,15,
	17,19,21,
	23,25,27,28,
	30,32,34,36};
void dfs(int top,int le,int l)
{
	if((ans-top)*3>=le)return;
	if(ans-top>=d[l-1])return;
	int i,x,y,z;
	ans=max(ans,top);
	for(i=l-1;i>=0;i--)
	{
		x=b[i][0],y=b[i][1],z=b[i][2];
		num[x]--,num[y]--,num[z]--;
		if(num[x]>=0 && num[y]>=0 && num[z]>=0)
			dfs(top+1,le-3,i);
		if(c[i]>1)
		{
			num[x]--,num[y]--,num[z]--;
			if(num[x]>=0 && num[y]>=0 && num[z]>=0)
				dfs(top+2,le-6,i);
			num[x]++,num[y]++,num[z]++;
		}
		num[x]++,num[y]++,num[z]++;
	}
}
int main()
{
	#ifndef ONLINE_JUDGE
	freopen("1.txt","r",stdin);
//	freopen("2.txt","w",stdout);
	#endif
	int i,j,k;
	int x,y,z;
//	init();
//	for(scanf("%d",&cass);cass;cass--)
	for(scanf("%d",&cas),cass=1;cass<=cas;cass++)
//	while(~scanf("%s",s))
//	while(~scanf("%d%d",&n,&m))
	{
		printf("Case #%d: ",cass);
		z=0;ans=0;
		for(i=1;i<10;i++)
		{
			scanf("%d",&num[i]);
			num[i]=min(num[i],17-i);
			z+=num[i];
		}
		if(num[9])i=20;
		else if(num[8])i=16;
		else if(num[7])i=12;
		else if(num[6])i=9;
		else if(num[5])i=6;
		else if(num[4])i=4;
		else if(num[3])i=2;
		else if(num[2])i=1;
		dfs(0,z,i);
		printf("%d\n",ans);
	}
	return 0;
}
/*
//

//
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值