The area (hdu1071)积分求面积

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7066 Accepted Submission(s): 4959


Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

 

Sample Input
2
5.000000
5.000000
0.000000
0.000000
10.000000
0.000000
10.000000
10.000000
1.000000
1.000000
14.000000
8.222222
 

 

Sample Output
33.33
40.69
Hint
For float may be not accurate enough, please use double instead of float.
 
 
 
一道高数题。
 
回顾一下微积分的知道,曲面的微积分。两个方程相减,对x或者y积分,就是面积。
然后具体的公式详见代码把,
 
 
#include<stdio.h>
//#include<math.h>与y1方法重载了、
double x1,y1,x2,y2,x3,y3;
double area;
double l,h,a,k,b;

//曲线的方程可用顶点式  y = a(x-h)^2+l, (h,l) 为顶点坐标)
//直线方程  y = kx+b;

//图形一定,只是点的位置不定。所以对x积分
double f(double x)
{
    return (a*x*x*x/3)-(a*h+k/2)*x*x+(a*h*h+l-b)*x;//积分,化简
}
int main()
{

    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
        h=x1;
        l=y1;
        a=(y2-y1)/((x2-h)*(x2-h));
        k=(y3-y2)/(x3-x2);
        b=y2-k*x2;
        printf("%.2lf\n",f(x3)-f(x2));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值