hdu-1071-The area-简单积分

Link: http://acm.hdu.edu.cn/showproblem.php?pid=1071

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9613    Accepted Submission(s): 6761

Problem Description

  Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

  Note: The point P1 in the picture is the vertex of the parabola.

这里写图片描述

Input

  The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
  Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output

  For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

Sample Output

33.33
40.69

Hint

For float may be not accurate enough, please use double instead of float.

Author
Ignatius.L

Recommend

We have carefully selected several similar problems for you:  1008 1021 1108 1019 1049 

过程
这里写图片描述

代码

#include <cstdio>
using namespace std;
double x1,x2,x3,y1,y2,y3;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
        long double a=(long double)(y2-y1)/((x1-x2)*(x1-x2));
        long double ans=(x3*x3*x3-x2*x2*x2)*a*2-3*a*(x3+x2)*(x3*x3-x2*x2)+y1*(x3-x2)*6+a*6*(x1*x1)*(x3-x2)+6*(x2*y3-y2*x3);
        ans/=6;
        printf("%.2f\n",(double)ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值