Median(vector+二分)

Median


Time Limit: 5 Seconds Memory Limit: 65536 KB

The median of m numbers is after sorting them in order, the middle one number of them if m is even or the average number of the middle 2 numbers if m is odd. You have an empty number list at first. Then you can add or remove some number from the list.

For each add or remove operation, output the median of the number in the list please.

Input

This problem has several test cases. The first line of the input is an integer T (0<T<=100) indicates the number of test cases. The first line of each test case is an integer n (0<n<=10000) indicates the number of operations. Each of the next n lines is either "add x" or "remove x"(-231<=x<231) indicates the operation.

Output

For each operation of one test case: If the operation is add output the median after adding x in a single line. If the operation is remove and the number x is not in the list, output "Wrong!" in a single line. If the operation is remove and the number x is in the list, output the median after deleting x in a single line, however the list is empty output "Empty!".

Sample Input
2
7
remove 1
add 1
add 2
add 1
remove 1
remove 2
remove 1
3
add -2
remove -2
add -1
Sample Output
Wrong!
1
1.5
1
1.5
1
Empty!
-2
Empty!
-1
Hint

if the result is an integer DO NOT output decimal point. And if the result is a double number , DO NOT output trailing 0s. 

 

 

题意:找中位数,由于数据比较大,用到了vector容器,

 

我也不会用,比赛前看过一点,可是不知道怎么用,so。。。比赛完,借大神的代码来观摩下,哈哈。我发现这个真的很好用。我一定要把他学会!!!

ps:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4736

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
vector<int>vet;
int deal(int x)
{
    int left=0,right=vet.size()-1;
    while(left<=right)
    {
        int mid=(left+right)/2;
        if(vet[mid]==x)
        {
            return mid;
        }
        else if(vet[mid]>x)
        {
            right=mid-1;
        }
        else
        {
            left=mid+1;
        }
    }
    return -1;
}
int erfen(int x)
{
    if(vet.size()==0) return 0;
    if(x<vet[0]) return 0;
    if(x>vet[vet.size()-1]) return vet.size();
    int left=0,right=vet.size()-1,k=-1;
    while(left<=right)
    {
        int mid=(left+right)/2;
        if(vet[mid]>=x&&vet[mid-1]<=x)
        {
            return mid;
        }
        else if(vet[mid]<=x&&vet[mid+1]>=x)
        {
            return mid+1;
        }
        else if(vet[mid]>x)
        {
            right=mid-1;
        }
        else left=mid+1;
    }
}
int main()
{
    int text;
    scanf("%d",&text);
    while(text--)
    {
        int n;
        scanf("%d",&n);
        vet.clear();
        vector<int>::iterator it=vet.begin();
        while(n--)
        {

            char ch[30];
            int x;
            scanf("%s%d",ch,&x);
            if(ch[0]=='r')
            {
                if(vet.size()==0)
                {
                    printf("Wrong!\n");
                    continue;
                }
                else
                {
                    int tmp=deal(x);
                    if(tmp==-1)
                    {
                        printf("Wrong!\n");
                        continue;
                    }
                    else
                    {
                        it=vet.begin();
                        vet.erase((it+tmp));
                        int len=vet.size();
                        if(len==0)
                        {
                            printf("Empty!\n");
                            continue;
                        }
                        else if(len%2==1)
                            cout<<vet[len/2]<<endl;
                        else
                        {
                            long long ans=(long long)vet[len/2]+(long long)vet[len/2-1];
                            if(ans%2==0)
                                printf("%lld\n",ans/2);
                            else
                            {
                                double sum=ans/2.0;
                                printf("%.1lf\n",sum);
                            }
                        }

                    }
                }
            }
            else
            {
                int tmp=erfen(x);
                it=vet.begin();
                vet.insert((it+tmp),x);
                int len=vet.size();
                if(len%2==1)
                    printf("%d\n",vet[len/2]);
                else
                {
                    long long ans=(long long)vet[len/2]+(long long)vet[len/2-1];
                    if(ans%2==0)
                        printf("%lld\n",ans/2);
                    else
                    {
                        double sum=ans/2.0;
                        printf("%.1lf\n",sum);
                    }
                }
            }
        }
    }
    return 0;
}

 

 

加油!!!加油!!!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值