Palindrome(补全回文串+最长公共子序列的应用)hdu1513+poj1159+动态规划

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4277    Accepted Submission(s): 1462


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 

Source
 


链接:http://acm.hdu.edu.cn/showproblem.php?pid=1513

题意:给出一个字符串,问要将这个字符串变成回文串要添加最少几个字符
思路:先求出正反串的最长公共子序列,然后剩下的两边加上就ok了。(以最长公共子序列为中心)

这里特别注意1000以上都需要要滚动数组,应该不然会超内存的。


#include<cstring>
#include<cstdio>
#include<iostream>
using namespace std;
int map[2][5005];//利用滚动数组
string str;
/***
题意:给出一个字符串,问要将这个字符串变成回文串要添加最少几个字符
思路:先求出正反串的最长公共子序列,然后剩下的两边加上就ok了。(以最长公共子序列为中心)
*/
void LCS(int &len1,int &len2)
{
    for(int i=0;i<=len1;i++)
    {
        for(int j=0;j<=len2;j++)
        {
            if(i==0||j==0) {map[i%2][j]=0; continue;}
            if(str[i-1]==str[len2-j]){ map[i%2][j]=map[(i-1)%2][j-1]+1;}
            else if(map[(i-1)%2][j]>=map[i%2][j-1]){ map[i%2][j]=map[(i-1)%2][j];}
            else { map[i%2][j]=map[i%2][j-1]; }
        }
    }
}
int main()
{
    int n;
    while(cin>>n)
    {
        cin>>str;
        LCS(n,n);
        int ans=map[n%2][n];
        cout<<n-ans<<endl;
    }
    return 0;
}

/*
5
Ab3bd
6
Ab34bd
5
Abb3f
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值