ZOJ3609

Modular Inverse
Time Limit: 2 Seconds Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist

8



--------------------------------------------------------------------------------------分割线--------------------------------------

数学题,枚举m,如下证明:

证明用到同余定理:因为ax%m=1%m
枚举x的范围1~m
假设x>m
a(m+x-m)%m=1%m
左边等价于(am%m+a(x-m)%m)%m .am%m=0 ((a(x-m))%m)%m=(a(x-m))%m
所以原式等价于(a(x-m))%m=1%m 所以x>m时,x-m的值必然已经在枚举x为1~m时出现过了。所以只要枚举1~m即可。


#include<stdio.h>
#include<string.h>
int main()
{
int t,x,a,m;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&a,&m);
int flag=0;
for(x=1;x<=m;x++)
{
if(a*x%m==1%m)
{
flag=1;
break;
}
}
if(flag)
printf("%d\n",x);
else
printf("Not Exist\n");
}
return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值