hdu 5012 Dice

Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 440    Accepted Submission(s): 259


Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)


Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A. 

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
 

Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 

Sample Input
  
  
1 2 3 4 5 6 1 2 3 4 5 6 1 2 3 4 5 6 1 2 5 6 4 3 1 2 3 4 5 6 1 4 2 5 3 6
 

Sample Output
  
  
0 3 -1
 

Source
 


题目及代码:


       直接光搜就可以了,最多搜索到5次就可以了。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

struct node
{
    int s[6];
    int step;
}l,r,t,tmp;

queue<node>Q;

bool judge(node t)
{
    for(int i=0;i<6;i++)
    if(t.s[i]!=r.s[i]) return false;
    return true;
}

void left(node &t)
{
    int tmp=t.s[3];
    t.s[3]=t.s[1];
    t.s[1]=t.s[2];
    t.s[2]=t.s[0];
    t.s[0]=tmp;
}

void right(node &t)
{
    int tmp=t.s[0];
    t.s[0]=t.s[2];
    t.s[2]=t.s[1];
    t.s[1]=t.s[3];
    t.s[3]=tmp;
}

void front(node &t)
{
    int tmp=t.s[5];
    t.s[5]=t.s[1];
    t.s[1]=t.s[4];
    t.s[4]=t.s[0];
    t.s[0]=tmp;
}

void back(node &t)
{
    int tmp=t.s[0];
    t.s[0]=t.s[4];
    t.s[4]=t.s[1];
    t.s[1]=t.s[5];
    t.s[5]=tmp;
}

int bfs()
{
    while(!Q.empty())
    {
        Q.pop();
    }
    Q.push(l);
    while(!Q.empty())
    {
        t=Q.front();
        Q.pop();
        if(t.step>=5) break;
        if(judge(t)) return t.step;


        t.step++;
        tmp=t;
        right(tmp);
        Q.push(tmp);

        tmp=t;
        left(tmp);
        Q.push(tmp);

        tmp=t;
        front(tmp);
        Q.push(tmp);

        tmp=t;
        back(tmp);
        Q.push(tmp);
    }
    return -1;
}
int main()
{
    while(scanf("%d",&l.s[0])!=EOF)
    {
        l.step=0;
        for(int i=1;i<6;i++)
        {
            scanf("%d",&l.s[i]);
        }
        for(int i=0;i<6;i++)
        {
            scanf("%d",&r.s[i]);
        }
        int n=bfs();
        printf("%d\n",n);
    }

    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值