hdu 5017 Ellipsoid(模拟退火)

Ellipsoid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1140    Accepted Submission(s): 412
Special Judge


Problem Description
Given a 3-dimension ellipsoid(椭球面)

your task is to find the minimal distance between the original point (0,0,0) and points on the ellipsoid. The distance between two points (x 1,y 1,z 1) and (x 2,y 2,z 2) is defined as 
 

Input
There are multiple test cases. Please process till EOF.

For each testcase, one line contains 6 real number a,b,c(0 < a,b,c,< 1),d,e,f (0 ≤ d,e,f < 1), as described above.  It is guaranteed that the input data forms a ellipsoid. All numbers are fit in double.
 

Output
For each test contains one line. Describes the minimal distance. Answer will be considered as correct if their absolute error is less than 10 -5.
 

Sample Input
  
  
1 0.04 0.01 0 0 0
 

Sample Output
  
  
1.0000000
 

Source
 

题解:
       这题也是看了看别人的题解,学习了一下模拟退火,感觉不难,挺简单。整体的思路就是8个方向的搜索,退火的意思就是逐渐缩小搜索范围,从而使最后的解足够精确。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
const double sp=0.99,eps=1e-8;
double a,b,c,d,e,f,M=1e9;
double dirx[]={-1,-1,-1,0,0,1,1,1};
double diry[]={-1,0,1,-1,1,-1,0,1};

double dis(double x,double y,double z)
{
    return sqrt(x*x+y*y+z*z);
}

double getz(double x,double y)
{
    double A=0,B=0,C=0;
    A=c;
    B=d*y+e*x;
    C=a*x*x+b*y*y+f*x*y-1;
    double delta=B*B-4*A*C;
    if(delta<0) return M;
    double z1=(sqrt(delta)-B)/(2.0*A),z2=(-sqrt(delta)-B)/(2.0*A);
    if(z1*z1<z2*z2) return z1;
    return z2;
}

double solve()
{
    double x=0,y=0,z=0,tx=0,ty=0,tz=0,step=1;
    z=getz(x,y);
    while(step>eps)
    {
        for(int i=0;i<8;i++)
        {
            tx=x+dirx[i]*step;
            ty=y+diry[i]*step;
            tz=getz(tx,ty);
            if(tz>=M) continue;
            if(dis(tx,ty,tz)<dis(x,y,z))
            {
                x=tx,y=ty,z=tz;
            }
        }
        step*=sp;
    }
    return dis(x,y,z);
}

int main()
{
    while(scanf("%lf%lf%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f)!=EOF)
    {
        printf("%.8lf\n",solve());
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值