ECNU_OJ_1006

Prime

Time Limit:1000MS Memory Limit:30000KB

Description

A prime is the number which can be only divide exactly by 1 or itself.

Input

There several test case. Each test case have two positive integer N,M in one line. (0

Output

For each test case, output one line that contain an integer that is the number of primes from N to M.

Sample Input

5 10
1 3
6 8

Sample Output

2
2
1

Source

Ecnu online judge

#include <stdio.h>
#include <math.h>
#include <malloc.h>

int main(int argc, char **argv)
{
    int i = 0;
    int j = 0;
    int *prime = (int *)malloc(sizeof(int) * 1000001);
    for(i = 3; i < 1000001; i+=2)
    {
        prime[i] = 1;
        prime[i + 1] = 0;
    }
    prime[2] = 1;
    for(i = 3; i < 1000001; i++)
    {
        if(prime[i] == 1)
        {
            for(j = i + i; j < 1000001; j += i)
                prime[j] = 0;
        }
    }

    unsigned int m = 0;
    unsigned int n = 0;

    while(scanf("%d%d", &m, &n) != EOF)
    {
        unsigned int count = 0;
        for(i = m; i <= n; i++)
            if(prime[i] == 1)
                count++;
        printf("%d\n", count);
    }
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值