二分图最小路径覆盖--poj2060

Language:
Taxi Cab Scheme
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5456 Accepted: 2283

Description

Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible,there is also a need to schedule all the taxi rides which have been booked in advance.Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.  
For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest,at least one minute before the new ride's scheduled departure. Note that some rides may end after midnight.

Input

On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.

Output

For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.

Sample Input

2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11

Sample Output

1
2

最小路径覆盖的题,把客人看做节点,根据A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest,at least one minute before the new ride's scheduled departure.如果送完这个客人可以在下一个客人出发之前赶到,则两
个客人之间是联通的,然后求出最大匹配m,n-m即为最终结果。

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
struct node
{
    int hour,miu;
    int a,b,c,d;
} edge[550];
int cab[550][550];
int vis[550],pre[550];
int n;
bool dfs(int u)
{
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&cab[u][i])
        {
            vis[i]=1;
            if(pre[i]==0||dfs(pre[i]))
            {
                pre[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    char a[10];
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(edge,0,sizeof(edge));
        for(int i=1; i<=n; i++)
        {
            cin>>a>>edge[i].a>>edge[i].b>>edge[i].c>>edge[i].d;
            sscanf(a,"%d:%d",&edge[i].hour,&edge[i].miu);

        }
        memset(cab,0,sizeof(cab));
        memset(pre,0,sizeof(pre));
        for(int i=1; i<=n; i++)
            for(int j=i+1; j<=n; j++)
            {
                int x=abs(edge[i].a-edge[i].c)+abs(edge[i].b-edge[i].d)+abs(edge[i].c-edge[j].a)+abs(edge[i].d-edge[j].b);
                int fen=edge[i].miu+x;
                int xiao=edge[i].hour;
                if(fen>=60)
                {
                    xiao=xiao+fen/60;
                    fen=fen%60;
                }
                if((xiao<edge[j].hour)||(xiao==edge[j].hour&&fen<edge[j].miu))
                    cab[i][j]=1;
            }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))
                ++ans;
        }
        cout<<n-ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值