二分图多重匹配+二分枚举-poj2112

Language:
Optimal Milking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 10381 Accepted: 3768
Case Time Limit: 1000MS

Description

FJ has moved his K (1 <= K <= 30) milking machines out into the cow pastures among the C (1 <= C <= 200) cows. A set of paths of various lengths runs among the cows and the milking machines. The milking machine locations are named by ID numbers 1..K; the cow locations are named by ID numbers K+1..K+C.  

Each milking point can "process" at most M (1 <= M <= 15) cows each day.  

Write a program to find an assignment for each cow to some milking machine so that the distance the furthest-walking cow travels is minimized (and, of course, the milking machines are not overutilized). At least one legal assignment is possible for all input data sets. Cows can traverse several paths on the way to their milking machine.  

Input

* Line 1: A single line with three space-separated integers: K, C, and M.  

* Lines 2.. ...: Each of these K+C lines of K+C space-separated integers describes the distances between pairs of various entities. The input forms a symmetric matrix. Line 2 tells the distances from milking machine 1 to each of the other entities; line 3 tells the distances from machine 2 to each of the other entities, and so on. Distances of entities directly connected by a path are positive integers no larger than 200. Entities not directly connected by a path have a distance of 0. The distance from an entity to itself (i.e., all numbers on the diagonal) is also given as 0. To keep the input lines of reasonable length, when K+C > 15, a row is broken into successive lines of 15 numbers and a potentially shorter line to finish up a row. Each new row begins on its own line.  

Output

A single line with a single integer that is the minimum possible total distance for the furthest walking cow.  

Sample Input

2 3 2
0 3 2 1 1
3 0 3 2 0
2 3 0 1 0
1 2 1 0 2
1 0 0 2 0

Sample Output

2

思路:先用folyed求最短路,然后二分枚举答案,建图用多重匹配判断是否可行。
为什么floyed的k写在外面才对,让我WA了半天,以前写floyed都是写在里面的。。。
下面是代码:
#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<cmath>
#include<climits>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
const int maxn=500;
const int INF=100000007;
int K,C,M;
int d[maxn][maxn];
int amount[maxn],pre[maxn][maxn];
int cow[maxn][maxn];
bool vis[maxn];

void floyed()
{
    int kc=K+C;
for(int k=1; k<=kc; k++)
 for(int i=1; i<=kc; i++) for(int j=1; j<=kc; j++) if(i!=j) if(d[i][j]>d[i][k]+d[k][j]) d[i][j]=d[i][k]+d[k][j];}void build(int mid){ memset(cow,0,sizeof(cow)); for(int i=1;i<=C;i++) { for(int j=1;j<=K;j++) if(d[i+K][j]<=mid) cow[i][j]=1; }}bool dfs(int u){ for(int i=1;i<=K;i++) { if(!vis[i]&&cow[u][i]) { vis[i]=1; if(amount[i]<M) { pre[i][++amount[i]]=u; return true; } for(int j=1;j<=amount[i];j++) { if(dfs(pre[i][j])) { pre[i][j]=u; return true; } } } } return false;}bool f(){ memset(amount,0,sizeof(amount)); for(int i=1;i<=C;i++) { memset(vis,0,sizeof(vis)); if(!dfs(i)) return false; } return true;}int main(){ //freopen("in.txt","r",stdin); cin>>K>>C>>M; int t=K+C; for(int i=1; i<=t; i++) { for(int j=1; j<=t; j++) { cin>>d[i][j]; if(d[i][j]==0) d[i][j]=INF; } } floyed(); int l=1,r=INF,mid; while(l<r) { mid=(r+l)/2; build(mid); memset(pre,0,sizeof(pre)); if(f()) r=mid; else l=mid+1; } cout<<l<<endl; return 0;}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值