最大流(EK)--poj1149

Language:
PIGS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14318 Accepted: 6375

Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs.  
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold.  
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses.  
An unlimited number of pigs can be placed in every pig-house.  
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N.  
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000.  
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line):  
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7


我忍不住想说脏话了,你个二货,居然是输入写错位置了,居然检查了半天,还wa了好几次。

这道题的讲解点击打开链接

#include<iostream>
#include<cstring>
#include<queue>
#include<climits>
#include<cstdio>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
int ans,s,t;
int vis[3010],con[310][310],pig[3010],fa[310];
int dis[310];
int bfs()
{
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    queue<int> p;
    dis[s]=inf;
    vis[s]=1;
    p.push(s);
    while(!p.empty())
    {
        int a=p.front();
        p.pop();
       // if(a==t)
         //   break;
        for(int i=0; i<=t; i++)
            if(!vis[i]&&con[a][i]>0)
            {
                vis[i]=1;
                dis[i]=min(dis[a],con[a][i]);
                fa[i]=a;
                p.push(i);
            }
    }
    return dis[t];
}
int EK()
{
    int d,res,flow=0;
    while((d=bfs())!=0)
    {
        flow+=d;
        for(int i=t;i!=s;i=fa[i])
        {
            con[fa[i]][i]-=d;
            con[i][fa[i]]+=d;
        }
    }
   return flow;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int n,m;
    int num;
    int p;
    while(cin>>m>>n)
    {
        s=0;t=n+1;
        for(int i=1; i<=m; i++)
            cin>>pig[i];
        memset(vis,0,sizeof(vis));
        memset(con,0,sizeof(con));
        for(int i=1; i<=n; i++)
        {
            cin>>num;
            for(int j=1; j<=num; j++)
            {
                cin>>p;
                if(vis[p]==0)
                {
                    con[s][i]+=pig[p];
                    vis[p]=i;
                    //vis[p]=i;
                }
                else
                {
                    con[vis[p]][i]=inf;
                }
                
            }
            cin>>con[i][t];
        }
        ans=0;
        ans+=EK();
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值