次短路--poj3255

Language:
Roadblocks
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5726 Accepted: 2167

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers:   N  and   R  
Lines 2.. R+1: Each line contains three space-separated integers:   A,   B, and   D  that describe a road that connects intersections   A  and   B  and has length   D  (1 ≤   D  ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node   N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

自己写的不对,不知道哪错了。
下面是AC的:
两次spfa

#include <iostream>
#include <queue>
using namespace std;
#define MAXV 5010
#define MAXE 200100
#define INF 1<<29

typedef struct{
	int t,w,next;
}Edge;
Edge edge[MAXE];

int d[MAXV],dr[MAXV];
int n,m,edge_sum;
int head[MAXV];
bool vis[MAXV];

void init(){
	memset(head,-1,sizeof(head));
	edge_sum=0;
	for(int i=1;i<=n;i++) d[i]=dr[i]=INF;
}

void addedge(int s,int t,int w){
	edge[edge_sum].t=t;
	edge[edge_sum].w=w;
	edge[edge_sum].next=head[s];
	head[s]=edge_sum++;
}

void spfa(int source,int dt[]){
	int i,v,u;
	queue <int>q;
	memset(vis,0,sizeof(vis));
	dt[source]=0;
	vis[source]=1;
	q.push(source);
	while(!q.empty()){
		v=q.front();q.pop();
		vis[v]=0;

		for(i=head[v];i!=-1;i=edge[i].next){
			u=edge[i].t;
			if(dt[v]+edge[i].w<dt[u]){
				dt[u]=dt[v]+edge[i].w;
				if(!vis[u]){
					vis[u]=1;
					q.push(u);
				}
			}
		}
	}
}

int main(){
	int a,b,c;
	int ans,tmp,i;
	while(~scanf("%d%d",&n,&m)){
		init();
		while(m--){
			scanf("%d%d%d",&a,&b,&c);
			addedge(a,b,c);
			addedge(b,a,c);
		}
		
		spfa(1,d);
		spfa(n,dr);

		ans=INF;
		for(i=1;i<=n;i++){
			for(int j=head[i];j!=-1;j=edge[j].next){
				b=edge[j].t;
				c=edge[j].w;
				tmp=d[i]+dr[b]+c;
				if(tmp>d[n] && ans>tmp){
					ans=tmp;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

自己写的:
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100015;
const int INF=1000000000;
struct node
{
    int to,cost,next;
} edge[maxn*2];
int N,R;
int pre[5010];
bool vis[5010];
int dis[5010];
int dis2[5010];
void dijkstra(int s)
{
    queue<int> q;
    fill(dis,dis+N+1, INF);
    fill(dis2,dis2+N+1,INF);
    fill(vis,vis+N+1, false);
    dis[s]=0;
    vis[s]=true;
    q.push(s);
    while(!q.empty())
    {
        int t=q.front();
        q.pop();
        for(int j=pre[t]; j; j=edge[j].next)
        {
            int v=edge[j].to;
            int d=dis[t]+edge[j].cost;
            if(dis[v]>d)
            {
                swap(dis[v],d);
                q.push(v);

            }
            if(dis2[v]>d&&dis[v]<d)
            {
                dis2[v]=d;
                q.push(v);
            }

        }
    }
    cout<<dis2[N]<<endl;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int from,to,f;
    while(cin>>N>>R)
    {
        int e=1;
        memset(pre,0,sizeof(pre));
        for(int i=1;i<=R;i++)
            edge[i].cost=INF;
        for(int i=1; i<=R; i++)
        {
            cin>>from>>to>>f;
            edge[e].next=pre[from];
            edge[e].to=to;
            edge[e].cost=f;
            pre[from]=e++;
            edge[e].next=pre[to];
            edge[e].to=from;
            edge[e].cost=f;
            pre[to]=e++;
        }
        dijkstra(1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值