贪心--poj3262

Language:
Protecting the Flowers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3371 Accepted: 1370

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer   N  
Lines 2.. N+1: Each line contains two space-separated integers,   Ti  and   Di, that describe a single cow's characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

首次是贪心性证明(大神的):
当前最优,因为每一次搬运之后剩下的问题和原问题一样,只是规模变小了,故如果每次选出当前最优的解来进行选取,则累计起来的解也是最优的.
所以这是一道贪心题.
选择策略,
1 在二个中间选择之中,能根据time/eat小的那个为最优解
证明:
二个羊中 A,B,属性分别为分别为eatA,timeA,eatB,timeB
选A的时候损失timeA*eatB
选B的时候损失timeB*eatA
双方同除以eatA*eatB.
令time/eat为一个羊的比率x
可以证明x小的那个为最优解.

定理,如果有一个选择在n个选择中是最优的,那么(在包含这个选择的)n-1个选择中也是最优的,

逆否命题,如果一个选择在n-1个选择中不是最优的,那么在n个选择中也不是最优的.

推论,如果一个选择在2个选择中不是最优的,那么在n个选择中也不是最优的

所以将羊按照比率x排序,可以找到一个羊A在与其它所有羊比较的过程中都是最优的,

或者说其它n-1的羊在与别的羊做两个之间选一个的选择的时候不是最优的,所有这n-1个羊不是最优解的.
所以羊A是n头羊中最优解

下面是代码:
#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<cmath>
#include<climits>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
struct node
{
    LL t,d;
    double ave;
}cow[100010];
bool cmp(node a,node b)
{
    if(fabs(a.ave-b.ave)<1e-9) return a.t<b.t;
    return a.ave>b.ave;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int N;
    while(cin>>N)
    {
        for(int i=0;i<N;i++)
        {
            cin>>cow[i].t>>cow[i].d;
            cow[i].ave=cow[i].d*1.0/cow[i].t;
        }
        sort(cow,cow+N,cmp);
        LL mint=2*cow[0].t;
        LL sum=0;
        for(int i=1;i<N;i++)
        {
            sum+=cow[i].d*mint;
            mint+=2*cow[i].t;
        }
        cout<<sum<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值