二分搜索(两次)-poj3579

Language:
Median
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3418 Accepted: 944

Description

Given N numbers, X1X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1X2, ... , XN, ( X≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

思路:先从小到大排序,然后二分枚举答案,判断是否可行,判断的时候再二分,统计与a[i]的值差距小于mid的数的个数,看是否小于
m。
下面是代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAX=100100;
int N,m;
int a[MAX];

int binary(int x,int y,int p,int d)
{
    if(x>y)
        return y;
    int mid=(x+y)/2;
    if(p-a[mid]<=d)
        return binary(x,mid-1,p,d);
    else
        return binary(mid+1,y,p,d);
}
bool can(int mid)
{
    int k=0,j;
    for(int i=2;i<=N;i++)
    {
        j=binary(1,i-1,a[i],mid);//找与a[i]差值比mid小的数的个数
        k+=i-j-1;
    }
    if(k>=m)
        return true;
    return false;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(cin>>N)
    {
        for(int i=1;i<=N;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+N+1);
        int l=0,r=2000000001,mid;
        //判断奇偶
        if((N*(N-1)/2)%2)
            m=(N*(N-1)/2+1)/2;
        else
            m=N*(N-1)/4;
        while(r>=l)
        {
            mid=(r+l)>>1;
            if(can(mid))
                r=mid-1;
            else
                l=mid+1;
        }
        cout<<l<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值