【POJ】3579Median(二分查找两数差值的中位数)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11700 Accepted: 4144

Description

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

Source

POJ Founder Monthly Contest – 2008.04.13, Lei Tao

题目大意:现在给你N个数,这N个数我们可以得到C(n,2)个数,取绝对值的,都是正值的,问你中位数是多少,其中如果其中有偶数个值的话,我们就输出m/2上的值就可以了

思路:这个题目我是用二分解决的,其中的差值是用绝对值的,这样的话,我经过sort排序后就可以找到二分的上下界:0~a[n]-a[1]。

其中比较费劲的也是比较难理解的我觉得就是那个ok的函数了,那个函数实际上是用来判断我们当前的差值的位置的,也就是来计算比我们的当前的差值还要小的数的个数的,

 

其中用到了upperbound这个函数,可以去查一下,是返回比最后一个参数大的第一个数的地址的,我们减去头位置之后就是他在数组中的位置了,     

其中一个式子:a[j]-a[i]<=d; ,a[j]<=a[i]+d,这个就是函数中那个式子的意思了,也就是遍历每一个找出所有的比他小的值,

还有就是后面的减去的值,就是减去不应该满足上述式子的数,也就是小于a[i]的数,所以那些数要减去

代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define ll long long
using namespace std;
const int maxn=100010;
int a[maxn];
int n,num,ans;
bool ok(int d)
{
    int cnt=0;
    for(int i=1;i<=n;i++)
    {
        int t=upper_bound(a+1,a+n+1,a[i]+d)-(a+1);
        cnt+=t-i;
    }
    if(cnt>=num)
        return true;
    else
        return false;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        int m=n*(n-1)/2;
        num=(m+1)/2;
        int low=0,high=a[n]-a[1];
        while(low<high)
        {
            int mid=(low+high)/2;
            if(ok(mid))
            {
                ans=mid;
                high=mid;
            }
            else
                low=mid+1;
        }
        cout<<ans<<endl;
    }
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值