数学(hdu5175Misaki's Kiss again)

Misaki's Kiss again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 820    Accepted Submission(s): 205


Problem Description
After the Ferries Wheel, many friends hope to receive the Misaki's kiss again,so Misaki numbers them 1,2...N1,N ,if someone's number is M and satisfied the GCD(N,M) equals to N XOR M ,he will be kissed again.

Please help Misaki to find all M(1<=M<=N) .

Note that:
GCD(a,b) means the greatest common divisor of a and b .
A XOR B means A exclusive or B
 

Input
There are multiple test cases.

For each testcase, contains a integets N(0<N<=1010)
 

Output
For each test case,
first line output Case #X:,
second line output k means the number of friends will get a kiss.
third line contains k number mean the friends' number, sort them in ascending and separated by a space between two numbers
 

Sample Input
  
  
3 5 15
 

Sample Output
 
 
Case #1: 1 2 Case #2: 1 4 Case #3: 3 10 12 14
Hint
In the third sample, gcd(15,10)=5 and (15 xor 10)=5, gcd(15,12)=3 and (15 xor 12)=3,gcd(15,14)=1 and (15 xor 14)=1


思路:暴力枚举所有的因子,在判断是不是符合条件

注意,有可能异火的结果大于N,要判断一下

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=101000;
typedef long long LL;
LL fac[maxn],ans[maxn];
LL N;
int cnt;
int cas;
void init()
{
    LL tmp=sqrt(N);
    cnt=0;
    for(LL i=1;i<=tmp;i++)
        if(N%i==0)
        {
            fac[cnt++]=i;
            if(i*i!=N){fac[cnt++]=N/i;}
        }
}
LL gcd(LL a,LL b)
{
    if(b==0)return a;
    return gcd(b,a%b);
}
void solve()
{
    int num=0;
    for(int i=0;i<cnt;i++)
        if((gcd(N,N^fac[i])==fac[i])&&((N^fac[i])<=N)&&((N^fac[i])!=0)&&(fac[i]!=N))
        ans[num++]=(N^fac[i]);
    sort(ans,ans+num);
    bool first=true;
    printf("Case #%d:\n%d\n",cas++,num);
    for(int i=0;i<num;i++)
    {
        if(first)first=false;
        else printf(" ");
        printf("%I64d",ans[i]);
    }
    printf("\n");
}
int main()
{
    cas=1;
    while(scanf("%I64d",&N)!=EOF)
    {
        init();
        solve();
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值