hdu 5175 Misaki's Kiss again(数论)

Misaki's Kiss again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1618    Accepted Submission(s): 412


Problem Description
After the Ferries Wheel, many friends hope to receive the Misaki's kiss again,so Misaki numbers them  1,2...N1,N ,if someone's number is M and satisfied the  GCD(N,M)  equals to  N  XOR  M ,he will be kissed again.

Please help Misaki to find all  M(1<=M<=N) .

Note that:
GCD(a,b)  means the greatest common divisor of  a  and  b .
A  XOR  B  means  A  exclusive or  B
 

Input
There are multiple test cases. 

For each testcase, contains a integets  N(0<N<=1010)
 

Output
For each test case, 
first line output Case #X:,
second line output  k  means the number of friends will get a kiss.
third line contains  k  number mean the friends' number, sort them in ascending and separated by a space between two numbers
 

Sample Input
  
  
3 5 15
 

Sample Output
  
  
Case #1: 1 2 Case #2: 1 4 Case #3: 3 10 12 14
Hint
In the third sample, gcd(15,10)=5 and (15 xor 10)=5, gcd(15,12)=3 and (15 xor 12)=3,gcd(15,14)=1 and (15 xor 14)=1

题意:给一个n,问有多少个1~n的数满足gcd(n,m)==n^m

思路:一开始想到把n进行整数分解,可是约数不止是质因子啊...比如30,约数可以是15

所以只能暴力枚举约数了,然后每次比较gcd(n,m)==i,m为n^i,i为n的约数,注意枚举到根号n即可O(10^5)可以承受

注意!!注意!!注意!!!

当m的个数为0时,后面依然要输出一个空行!PE了无数次的我如是说道。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
long long gcd(long long a,long long b)
{
    return b?gcd(b,a%b):a;
}
long long ans[1000000];
int main()
{
    long long n;
    int t=1;
    while(~scanf("%lld",&n))
    {
       long long num=0;
       for(long long i=1;i*i<=n;i++)
       {
           if(n%i!=0) continue;
           long long m=n^i;
           if(m>=1&&m<=n&&gcd(n,m)==i) ans[num++]=m;
           if(i*i==n||i==1) continue;
           m=n^(n/i);
           if(m>=1&&m<=n&&gcd(n,m)==n/i) ans[num++]=m;
       }
       printf("Case #%d:\n%lld\n",t++,num);
       sort(ans,ans+num);
       for(int i=0;i<num;i++)
       {
           if(i!=0) printf(" ");
           printf("%lld",ans[i]);
       }
       printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值