HDU 1242 Rescue


HDU 1242 题目链接


Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12869    Accepted Submission(s): 4712


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1240  1016  1241  1372  1312 
 



//---------------------------------------------------------------------------------------------------------------------------------------
//---------------------------------------------------------------------------------------------------------------------------------------




不知道怎么的最近写题目很粗心

就这道题吧,之前A过了,现在重敲了一遍,然后呵呵呵呵的一排过去


1  scanf( "%d%d" , &n , &m );  居然漏了一个 %d 写成 scanf( "%d" , &n , &m );

2   main函数里忘了调用bfs()函数,漏掉 bfs(); 一句

3  printf( "%d\n" , ans );  也能漏掉一个 \n  

4  vis[sx][sy] = true;  同漏

呵呵呵呵呵又是一排过去

最后是,原本是用 r 做起点 a 做终点去做 , 可是没想到人家 angle 是有好多朋友的啊呵呵呵呵呵哭了

于是改掉用a做起点 r去判断终状态


于是有了下面的代码








#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;

int n , m ;
char map[205][205];
bool vis[205][205];
int dir[4][2] = { 1 , 0 , -1 , 0 , 0 , 1 , 0 , -1 };
int sx , sy , ex , ey , ans ;

struct node{
    int x , y ;
    int time;
    bool check(){
        if( x<0 || x>=n || y<0 || y>=m || map[x][y] == '#' )
            return false;
        return true;
    }
};

void bfs(){
    node now , next;
	now.x = sx ;
	now.y = sy ;
	now.time = 0 ;
	vis[sx][sy] = true;
	queue<node> q;
	q.push(now);
	while( !q.empty() ){
		now = q.front();
		q.pop();
		if( map[now.x][now.y] == 'r' ){
			ans = now.time;
			return ;
		}
		for( int i = 0 ; i < 4 ; ++i ){
			next.x = now.x + dir[i][0];
			next.y = now.y + dir[i][1];
			next.time = now.time;
			if( !next.check() ) continue;
			if( vis[next.x][next.y] ) continue;
			if( map[next.x][next.y] == 'x' )
				next.time += 2;
			else
				next.time += 1;
			vis[next.x][next.y] = true;
			q.push(next);
		}
	}
    return ;
}

int main(){
    while( scanf( "%d%d" , &n , &m ) != EOF ){
        for( int i = 0 ; i < n ; ++i ){
            char tmp[205];
            scanf( "%s" , tmp );
            for( int j = 0 ; j < m ; ++j ){
                map[i][j] = tmp[j] ;
                if( tmp[j] == 'a' )
                    sx = i , sy = j;
            }
        }
        memset( vis , false , sizeof(vis) );
        ans = -1;
        bfs();
        if( ans != -1 )
            printf( "%d\n" , ans );
        else
            printf( "Poor ANGEL has to stay in the prison all his life.\n" );
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值