PAT-A | 1005 | Spell It Right

1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

解题思路:

1. 由于N <= 10 ^100,所以用char * 存放N;

2. 从头到尾把N的每一位加起来得到value;

3. 从尾到头把value的每一位push到一个简单栈里面;

4. 自顶向下把栈的每一位pop出来(也就是把value从高位到低位),每pop出来一位,输出对应的英文


代码如下:

// PAT-A 1005
// 2015/9/9 15:50 - 16:15
// author: Kaituo Xu

#include <iostream>

using namespace std;

int main()
{
	char *n;
	int value = 0;
	int i = 0;

	n = new char[101];
	cin >> n;

	//sum every digit of n
	while (*n != '\0') {
		value += *n++ - '0';
	}
	//cout << value << endl;

	int stack[101], top = -1;
	//this if statement is aviod the case in which value equal to 0.
	if (value == 0) {
		stack[++top] = value;
	}
	//push every digit of value to a stack
	while (value != 0) {
		stack[++top] = value % 10;
		value /= 10;
	}
	// from highest digit to lowest digit(stack top-down), output correspond English
	while (top != -1) {
		switch (stack[top--]) {
		case 0:
			cout << "zero";
			break;
		case 1:
			cout << "one";
			break;
		case 2:
			cout << "two";
			break;
		case 3:
			cout << "three";
			break;
		case 4:
			cout << "four";
			break;
		case 5:
			cout << "five";
			break;
		case 6:
			cout << "six";
			break;
		case 7:
			cout << "seven";
			break;
		case 8:
			cout << "eight";
			break;
		case 9:
			cout << "nine";
			break;
		}
		// avoid extra space at the end of a line
		if (top == -1) {
			cout << endl;
		} else {
			cout << " ";
		}
	}
}
//test data
//1.
//9999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999
//2.
//0
//3.
//12345




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值