hanoi双塔

hanoi双塔

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 3
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

给定a、b、c三根足够长的细柱,在a柱上放有2n(n<=200)个中间有孔的圆盘,共有n个不同的尺寸,每个尺寸都有两个相同的圆盘,注意这两个圆盘是不加区分的。尺寸相同的圆盘在一起。
现在将这些圆盘移动到c柱上,在移动过程中可放在b柱上暂存。要求:
(1) 每次只能移动一个圆盘;
(2) a、b、c三根细柱上的圆盘都要保持上小下大的顺序。
请问完成上述任务所需的最少移动次数。

Input

输入第一行为T,表示数据组数,对于每组数据就一个n,表示在a柱上放有2n个圆盘。

Output

对于每组输入,输出完成上述任务所需的最少移动次数。

Sample Input

2
1
2

Sample Output

2
6

#include<iostream>
#include<string.h>
#include<iomanip>
#include<algorithm>
using namespace std;
class BigNum;
istream& operator>>(istream&,  BigNum&);
ostream& operator<<(ostream&,  BigNum&);
#define MAXN 9999
#define MAXSIZE 20000
#define DLEN 4
class BigNum
{
public:
    int a[MAXSIZE];
    int len;
public:
    BigNum()
    {
        len = 1;
        memset(a,0,sizeof(a));
    }
    BigNum(const int);
    BigNum(const char*);
    BigNum(const BigNum &);
    BigNum &operator=(const BigNum &);
    friend istream& operator>>(istream&,  BigNum&);
    friend ostream& operator<<(ostream&,  BigNum&);
    BigNum operator+(const BigNum &) const;
    BigNum operator-(const BigNum &) const;
    BigNum operator*(const BigNum &) const;
    BigNum operator/(const int  &) const;
    BigNum operator^(const int  &) const;
    int    operator%(const int  &) const;
    bool   operator>(const BigNum & T)const;
    bool   operator==(const BigNum & T)const;
    bool   operator==(const int & t)const;
    bool   operator>(const int & t)const;

};

//输入 。。。。。。。。。。。。。。。。
istream& operator>>(istream & in,  BigNum & b)
{
    char ch[MAXSIZE*4];
    int i = -1;
    memset(b.a,0,sizeof(b.a));
    in>>ch;
    int l=strlen(ch);
    int count=0,sum=0;
    for(i=l-1; i>=0;)
    {
        sum = 0;
        int t=1;
        for(int j=0; j<4&&i>=0; j++,i--,t*=10)
        {
            sum+=(ch[i]-'0')*t;
        }
        b.a[count]=sum;
        count++;
    }
    b.len =count++;
    return in;

}

/输出 。。。。。。。。。。。。。。
ostream& operator<<(ostream& out,  BigNum& b)
{
    int i;
    cout << b.a[b.len - 1];
    for(i = b.len - 2 ; i >= 0 ; i--)
    {
        cout.width(DLEN);
        cout.fill('0');
        cout << b.a[i];
    }
    return out;
}
VIP/
BigNum::BigNum(const int b)
{
    int c,d = b;
    len = 0;
    memset(a,0,sizeof(a));
    while(d > MAXN)
    {
        c = d - (d / (MAXN + 1)) * (MAXN + 1);
        d = d / (MAXN + 1);
        a[len++] = c;
    }
    a[len++] = d;
}
BigNum::BigNum(const char*s)
{
    int t,k,index,l;
    memset(a,0,sizeof(a));
    l=strlen(s);
    len=l/DLEN;
    if(l%DLEN)len++;
    index=0;
    for(int i=l-1; i>=0; i-=DLEN)
    {
        t=0;
        k=i-DLEN+1;
        if(k<0)k=0;
        for(int j=k; j<=i; j++)
            t=t*10+s[j]-'0';
        a[index++]=t;
    }
}
BigNum::BigNum(const BigNum & T) : len(T.len)
{
    int i;
    memset(a,0,sizeof(a));
    for(i = 0 ; i < len ; i++)  a[i] = T.a[i];
}
VIP//


大数与大数的赋值。。。。。。。。。。。。
BigNum & BigNum::operator=(const BigNum & n)
{
    len = n.len;
    memset(a,0,sizeof(a));
    for(int i = 0 ; i < len ; i++)
        a[i] = n.a[i];
    return *this;
}

大数与大数的加法。。。。。。。。。。。。
BigNum BigNum::operator+(const BigNum & T) const
{
    BigNum t(*this);
    int i,big;
    big = T.len > len ? T.len : len;
    for(i = 0 ; i < big ; i++)
    {
        t.a[i] +=T.a[i];
        if(t.a[i] > MAXN)
        {
            t.a[i + 1]++;
            t.a[i] -=MAXN+1;
        }
    }
    if(t.a[big] != 0) t.len = big + 1;
    else t.len = big;
    return t;
}

大数与大数的减法。。。。。。。。。。。。
BigNum BigNum::operator-(const BigNum & T) const
{
    int i,j,big;
    bool flag;
    BigNum t1,t2;
    if(*this>T)
    {
        t1=*this;
        t2=T;
        flag=0;
    }
    else
    {
        t1=T;
        t2=*this;
        flag=1;
    }
    big=t1.len;
    for(i = 0 ; i < big ; i++)
    {
        if(t1.a[i] < t2.a[i])
        {
            j = i + 1;
            while(t1.a[j] == 0) j++;
            t1.a[j--]--;
            while(j > i) t1.a[j--] += MAXN;
            t1.a[i] += MAXN + 1 - t2.a[i];
        }
        else t1.a[i] -= t2.a[i];
    }
    t1.len = big;
    while(t1.a[len - 1] == 0 && t1.len > 1)
    {
        t1.len--;
        big--;
    }
    if(flag)t1.a[big-1]=0-t1.a[big-1];
    return t1;
}


大数与大数的乘法。。。。。。。。。。。。
BigNum BigNum::operator*(const BigNum & T) const
{
    BigNum ret;
    int i,j,up;
    int temp,temp1;
    for(i = 0 ; i < len ; i++)
    {
        up = 0;
        for(j = 0 ; j < T.len ; j++)
        {
            temp = a[i] * T.a[j] + ret.a[i + j] + up;
            if(temp > MAXN)
            {
                temp1 = temp - temp / (MAXN + 1) * (MAXN + 1);
                up = temp / (MAXN + 1);
                ret.a[i + j] = temp1;
            }
            else
            {
                up = 0;
                ret.a[i + j] = temp;
            }
        }
        if(up != 0)
            ret.a[i + j] = up;
    }
    ret.len = i + j;
    while(ret.a[ret.len - 1] == 0 && ret.len > 1) ret.len--;
    return ret;
}


大数与int的除法。。。。。。。。。。。。
BigNum BigNum::operator/(const int & b) const
{
    BigNum ret;
    int i,down = 0;
    for(i = len - 1 ; i >= 0 ; i--)
    {
        ret.a[i] = (a[i] + down * (MAXN + 1)) / b;
        down = a[i] + down * (MAXN + 1) - ret.a[i] * b;
    }
    ret.len = len;
    while(ret.a[ret.len - 1] == 0 && ret.len > 1) ret.len--;
    return ret;
}

大数与int的取余。。。。。。。。。。。。
int BigNum::operator %(const int & b) const
{
    int i,d=0;
    for (i = len-1; i>=0; i--)
    {
        d = ((d * (MAXN+1))% b + a[i])% b;
    }
    return d;
}

大数幂。。。。。。。。。。。。
BigNum BigNum::operator^(const int & n) const
{
    BigNum t,ret(1);
    int i;
    if(n<0)exit(-1);
    if(n==0)return 1;
    if(n==1)return *this;
    int m=n;
    while(m>1)
    {
        t=*this;
        for( i=1; i<<1<=m; i<<=1)
        {
            t=t*t;
        }
        m-=i;
        ret=ret*t;
        if(m==1)ret=ret*(*this);
    }
    return ret;
}

//大数 大小判断。。 。。。。。。。。。。。。。
bool BigNum::operator>(const BigNum & T) const
{
    int ln;
    if(len > T.len) return true;
    else if(len == T.len)
    {
        ln = len - 1;
        while(a[ln] == T.a[ln] && ln >= 0) ln--;
        if(ln >= 0 && a[ln] > T.a[ln]) return true;
        else return false;
    }
    else return false;
}

//大数相等判断。。。。。。。。。。。。
bool BigNum::operator==(const BigNum & T) const
{
    int ln;
    if(len != T.len) return false;
    else
    {
        ln = len - 1;
        while(a[ln] == T.a[ln] && ln-- );
        if(ln < 0) return true;
        else return false;
    }
}

//大数与int 大小判断。。。。。。。。。。。。
bool BigNum::operator >(const int & t) const
{
    BigNum b(t);
    return *this>b;
}


bool BigNum::operator==(const int & t) const//大数 与int相等判断。。。。。。。。。。。。
{
    BigNum b(t);
    return *this==b;
}




int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        BigNum a(2);
        cin>>n;
        a=((a^n)-1)*2;
        cout<<a<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值