POJ_1050_To the Max(最大子矩阵和)

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37319 Accepted: 19662

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source


题型:DP


题意:找出矩阵中和最大的子矩阵,只需输出最大和的值。


分析

首先看一下只有一列数的情况,例如:

求下面这一串数的最大和连续子串,对下面这串数作DP:

   a--->2 3 -7 2 -1 8 

DP--->2 5 -2 2  1 9

因为是连续若干个自然数的和,所以前面的某个数字取与不取的条件就是:以前面这个数字为结尾的连续数的和最大值是否大于0,如果大于0,那么这个数字必然要会出现在包括数字的序列中,否则无法做到最大。

所以   dp[i]=max(0,dp[i-1])+a[i];

然后将dp[]遍历一遍找出最大值即可。

现在推广到二维数组中:

我们可以将二维压成一维,即枚举一段区间,求出其和,以样例为例:

                    0 -2 -7 0
                    9 2 -6 2
                    -4 1 -4 1
                    -1 8 0 -2

我们枚举这些行,假如枚举到第二行到第四行

                     9 2 -6 2 
                    -4 1 -4 1 
                    -1 8 0 -2

每一列的和sum是  4 11 -10 1;

作dp--------------->  4  15   5  6.

所以在第二行到第四行这一段中和最大的子矩阵的和是15。

即                 9 2

                   -4 1

                   -1 8


代码:

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    int a[150][150],sum[150],dp[150];
    int n;
    while(~scanf("%d",&n)){
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                scanf("%d",&a[i][j]);
            }
        }
        int maxn=-1;
        for(int i=0;i<n;i++){
            memset(sum,0,sizeof(sum));
            for(int j=i;j<n;j++){
                for(int k=0;k<n;k++){
                    sum[k]+=a[j][k];
                }
                dp[0]=sum[0];
                for(int k=1;k<n;k++){
                    dp[k]=max(0,dp[k-1])+sum[k];
                }
                for(int k=0;k<n;k++){
                    maxn=max(dp[k],maxn);
                }
            }
        }
        printf("%d\n",maxn);

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值