hdu_4236_Repeating Characters(水题)

Repeating Characters
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

For this problem, you will write a program that takes a string of characters, S, and creates a new string of characters, T, with each character repeated R times. That is, R copies of the first character of S, followed by R copies of the second character of S, and so on. Valid characters for S are the QR Code ``alphanumeric'' characters:

0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ$%*+-./:

Input

The first line of input contains a single integer P, ( 1$ \le$P$ \le$1000), which is the number of data sets that follow. Each data set is a single line of input consisting of the data set number N, followed by a space, followed by the repeat count R, ( 1$ \le$R$ \le$8), followed by a space, followed by the string S. The length of string S will always be at least one and no more than 20 characters. All the characters will be from the set of characters shown above.

Output

For each data set there is one line of output. It contains the data set number, N, followed by a single space which is then followed by the new string T, which is made of each character in S repeated R times.

Sample Input

2
1 3 ABC
2 5 /HTP

Sample Output

1 AAABBBCCC
2 /HHHHHTTTTTPPPPP

题型:大水题


题意:就是将字符串中的每个字符重复输出p遍。


分析:话说这批题目还真是奇葩,还要输出行号,一开始咋都木有看懂这最前面的数是啥子玩意儿,结果发现单纯的我被这单纯的行号给单纯地伤害了。。。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
char s[50];

int main(){
    int t,n,p;
    while(~scanf("%d",&t)){
        while(t--){
            scanf("%d%d%s",&n,&p,s);
            printf("%d ",n);
            for(int i=0;i<strlen(s);i++){
                int cnt=0;
                while(cnt<p){
                    printf("%c",s[i]);
                    cnt++;
                }
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值