pku1365 Prime Land 小整数素数分解,基础题

Prime Land
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2677 Accepted: 1269

Description

Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0,1,2,... denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers e kx, e kx-1, ..., e 1, e 0, (e kx > 0), that   The sequence 

(e kx, e kx-1, ... ,e 1, e 0



is considered to be the representation of x in prime base number system. 

It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple. 

Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''. 

Help people in the Prime Land and write a corresponding program. 

For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi. 

Input

The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number 0.

Output

The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There is no line in the output corresponding to the last ``null'' line of the input.

Sample Input

17 1
5 1 2 1
509 1 59 1
0

Sample Output

2 4
3 2
13 1 11 1 7 1 5 1 3 1 2 1


题意:题目给一个用因子表示的数,我们转换成因子从小到大的的序列,

给你一个数的,素数次幂乘积形式的表示让你求出这个数减一的素数次幂乘积的表示形式。

首先打一个素数表,然后把输入存成字符串形式,在还原成数,再分解,再输出。



#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int LEN=20000;
int isprime[LEN], prime[LEN], arr[LEN];
int p[LEN], e[LEN], pk, ek;
char s[LEN];
void getprime()
{
    int i, j, k;
    for(i=2; i<LEN; i+=2)
    {
        isprime[i]=0;
        isprime[i+1]=1;
    }
    prime[ prime[0]=1 ]=2;
    for(i=3; i*i<LEN; i+=2)
    {
        if( isprime[i] )
        {
            for(j=i*i, k=2*i; j<LEN; j+=k)
            {
                isprime[j]=0;
            }
        }
    }
    for(i=3; i<LEN; i+=2)
        if( isprime[i] ) prime[ ++prime[0] ]=i;
//    for(i=0; i<30; i++)
//        cout<<prime[i]<<" ";
//    cout<<endl;
}
int restore()
{
    //cout<<"restore\n";///
    int num, i, j, temp;
    int len=strlen(s);
    temp=0;
    for(i=j=0; i<len; i++)
    {
        if( s[i]==' ' )
        {
            arr[j++]=temp;
         //   cout<<"restore "<<arr[j-1]<<endl;///
            temp=0;
        }
        else
            temp= temp*10+(s[i]-'0');
    }
    arr[j++]=temp;
   // cout<<temp<<endl;
    num=temp=1;
    for(i=0; i<j; i+=2)
    {
        temp=arr[i];
        for(int k=1; k<arr[i+1]; k++)
        {
            temp*=arr[i];
        }
        num*=temp;
    }
   // cout<<" num-1 = "<<num-1<<endl;//
    return num-1;
}
void resolve(int& num)
{
    int i, j, k, t;
    j=0;
    for(i=1; prime[i]*prime[i]<=num; i++)
    {
        t=0;
        if( (num%prime[i])==0 )
        {
        //    cout<<"this step\n";
            num/=prime[i];
            t++;
            while( (num%prime[i])==0 )
            {
                num/=prime[i];
                t++;
            }
         //   cout<<"resolve "<<t << " = t, prime[i]= "<<prime[i]<<endl;
            p[j]=prime[i];
            e[j++]=t;
        }
    }
    if( num>1 )
    {
        p[j]=num;
        e[j++]=1;
    }
    pk=j;
}
void print()
{
    int i;
    cout<<p[pk-1]<<" "<<e[pk-1];
    for(i=pk-2; i>=0; i--)
        cout<<" "<<p[i]<<" "<<e[i];
    cout<<endl;
}
int main()
{
    int i, j;
    getprime();
    while( gets(s) )
    {
        if( strcmp(s, "0")==0 ) break;
        int num=restore();
        resolve(num);
        print();
    }
    return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值