hdu 1017 A Mathematical Curiosity

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
  
  
1 10 1 20 3 30 4 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 4 Case 3: 5
 
刚开始做这道题就感觉很简单,可是提交了之后都是PE,感觉没啥错误,后来又看了一遍题,发现格式是这样的 Case  1:  2,希望大家做题的时候注意
题目大意:
第一行就是要测试数据的组数(就是那么多的数据作为一组)。 然后下边的数据就是每一小组要测试的数据 并且每一小组以0 0结束,每一行结果要换行,每一组要换行,其中最后一大组结束时不换行。否则,就会Presentation Error。我试过的。
3

10 1
2 5
3 3
6 8
0 0

2 9
3 7
0 0

6 6
5 4 
9 8
0 0


#include <iostream>
using namespace std;
int main()
{
	int t;
	while(cin>>t)
	{
		for(int i=0;i<t;i++)
		{
		  int n,m,sum;	
		  int k=1;
		  while(cin>>n>>m)
		  {
			sum=0;
			if(n==0&&m==0)
            break;
			for(int i=1;i<n;i++)
			{
				for(int j=i+1;j<n;j++)
				{
					if((i*i+j*j+m)%(i*j)==0)
					{
						sum++;
					}
				}
			}
		cout<<"Case "<<k++<<": "<<sum<<endl;
		}
		if(i!=t-1)
		cout<<endl;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值