HDU-1017 A Mathematical Curiosity

HDU-1017 A Mathematical Curiosity

Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 65536/32768K (Java/Other)

Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input
1

10 1
20 3
30 4
0 0
Sample Output
Case 1: 2
Case 2: 4
Case 3: 5


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1017

分析

题意:给定两个整数n和m,计算整数对(a,b)的个数,使得0 < a < b < n并且(a ^ 2 + b ^ 2 + m)/(a*b)是一个整数。题意大概就是这样。

思路:比较坑的水题,多实例测试,首先就是输入0 0才表示一个模块的结束,而且每两个模块的输出之间有一个空行,并且最后一个模块最后没有换行。直接用两个for和一个判断就可以解决了。

代码
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int n;
    cin>>n;
    while (n--)
    {
        int flag=0;
        while (1)
        {
            int sum=0;
            int x,y;
            cin>>x>>y;
            if (x==0&&y==0)
                break;
            for (int i=1;i<x;i++)
            {
                for (int j=i+1;j<x;j++)
                {
                    if ((i*i+j*j+y)%(i*j)==0)
                        sum++;
                }
            }
            flag++;
            cout<<"Case "<<flag<<": "<<sum<<endl;
        }
        if (n!=0)
            cout<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值