比赛 I - 0 or 1

Description

Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he always try to get a hand. Now the problem is coming! Let we
define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n). 
 

Input

The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.
 

Output

For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .
 

Sample Input

    
    
3 1 2 3
 

Sample Output

    
    
1 0 0

Hint

Hint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8
     S(3) % 2 = 0  
 

一开始做题的时候就理解错题意了,没有看到divided n,就理解为T(n)=1+n,(n>1),于是就用最简单的方法写的,但是结果超时了,后来才发现是理解错题意了,题意其实很简单,其中有规律的,我列了大量的数据才发现:
只有T[i*i]和T(i*i*2)为1,,其余的都为0,但是在写代码的过程中要注意是哪个在前哪个在后。所以:
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int n;
    int m,sum;
    cin>>n;
    while(n--)
    {
        scanf("%d",&m);
        sum=0;
        for(int i=1; i<=m; i++)
        {
            if(i*i*2<=m)
                sum++;
            if(i*i<=m)
                sum++;
            //if(i*i*2<=m)
            //sum++;
            else
                break;
            //cout<<sum<<endl;
        }
        //cout<<sum<<endl;
        cout<<sum%2<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值