HDU 1312 Red and Black (DFS入门)

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1016  1242  1253  1240  1072 


题意:有红格子和黑格子。人只能走黑格子。数人能走多少个黑格子并输出。
转化后为数‘@’周围的‘.’的数量:
典型的DFS深搜........但是我一开始提交的时候老师CE,不知道什么原因,感觉代码很对,不知道什么原因,后来就想是不是用G++是原因,所以就用C++试了试,然后就AC了......
#include <iostream>
#include <cstring>
using namespace std;

char str[25][25];
int xx,yy;
int w,h;
int count;
int dist[4][2]= {0,1,1,0,0,-1,-1,0};
void dfs(int x,int y)
{
    int sx,sy;
    for(int i=0; i<4; i++)
    {
        sx=x+dist[i][0];
        sy=y+dist[i][1];
        if(sx>=1&&sx<=h&&sy>=1&&sy<=w&&str[sx][sy]=='.')
        {
            count++;
            str[sx][sy]='#';
            dfs(sx,sy);
        }
    }
}
int main()
{
    while(cin>>w>>h)
    {
        if(w==0&&h==0)
            break;
        for(int i=1; i<=h; i++)
            for(int j=1; j<=w; j++)
            {
                cin>>str[i][j];
                if(str[i][j]=='@')
                {
                    xx=i;
                    yy=j;
                }
            }
        count=1;
        str[xx][yy]='#';
        dfs(xx,yy);
        cout<<count<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值