ZOJ 1850 Beautiful Meadow


Tom's Meadow

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

  1. Not all squares are covered with grass.
  2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers NM (1 <= NM <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No



题目大意:
1:不能所有的都是1

2:不能有0相邻

不是所有的格子都是草地,并且相邻不能没有草地。

下面两种情况都是不漂亮的,除此之外的任何情况,都是漂亮的:
1.全是1,不漂亮。这样就包括一种情况,整个草坪只有一个方块,如果方块的草没有被剪去,那就不漂亮。

2.两个方块共一条边,即前后两个元素或者上下两个元素都是 00.

#include <iostream>
using namespace std;

int main()
{
    int p[10][10];
    int n,m;
    bool flag;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        flag=true;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                cin>>p[i][j];
                if(!p[i][j])
                flag=false;
            }
        if(flag)
        {
            cout<<"No"<<endl;
            goto RL;
        }
        for(int k=1; k<m; k++)
            if(p[0][k]==0&&p[0][k-1]==0)
            {
                cout<<"No"<<endl;
                goto RL;
            }

        for(int i=1; i<n; i++)
            for(int j=0; j<m; j++)
            {
                if(p[i][j]==0&&p[i-1][j]==0)
                {
                    cout<<"No"<<endl;
                    goto RL;
                }
                if(j!=0)
                {
                    if(p[i][j]==0&&p[i][j-1]==0)
                    {
                        cout<<"No"<<endl;
                        goto RL;
                    }
                }
            }
        cout<<"Yes"<<endl;
        continue;
RL:
        continue;
    }
    return 0;
}

第二种方法:
#include<stdio.h>
int main()
{
    int a[12][12],x,y,i,j,sum,flag;
    while(scanf("%d%d",&x,&y)!=EOF&&x&&y)
    {
        flag=sum=0;
        for(i=0; i<12; i++) //初始化
        {
            for(j=0; j<12; j++)
            {
                a[i][j]=2;//所有点为2
            }
        }
        for(i=1; i<=x; i++) //i和j都从1开始,好控制边界
        {
            for(j=1; j<=y; j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(i=1; i<=x; i++)
        {
            for(j=1; j<=y; j++)
            {
                sum+=a[i][j];
                if(a[i][j]==0)
                {
                    if(a[i][j-1]&&a[i][j+1]&&a[i-1][j]&&a[i+1][j])
                        continue;
                    flag=1;
                }
            }
        }
        if(sum==x*y||flag)
            printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值