九度OJ Graduate Admission

  It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
    Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

    • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
    • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
    • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
    • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:

    Each input file may contain more than one test case.
    Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
    In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
    Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:

    For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
样例输出:
0 10
3
5 6 7
2 8

1 4

题目意思:

第一行输入三个数字,n,m,k,其中n表示学生人数,m表示学校数,k表示每个学生的选择。

第二行,根据输入的数字m,依次输入m个学校的招生人数,在代码中用admit定义。

之后输入n行数据,每行数据内容:ge成绩,gi成绩,以及k个选择。

关于录取规则:

1.定义每个学生的id,计算每个学生的平均成绩avg=(ge+gi)/2,根据avg成绩排序,如果学生avg成绩相等,根据ge成绩排序。

排好序之后,依次访问每个学生的学校选择,注意:如果遇到avg成绩和ge成绩都相等的学生,则用temp标记,如果学校招了一个学生之后没有名额了,也要将temp标记的学生接收。

2.输出时,按照从小到大的顺序直接输出学生的id编号,

如果学校没有接收到学生,直接输出空行。

#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
struct student
{
	int id;
	int ge,gi;
	int avg;
	int temp;//标记
	int school[10];
};
bool cmp(const student a,const student b)//根据成绩排序
{
	if(a.avg==b.avg)
		return a.ge>b.ge;
	return a.avg>b.avg;
}
student s[40001];
int main()
{
	int n,m,k;
	int quota[101];
	int admit[101];
	while(cin>>n>>m>>k)
	{
		vector<int> ans[101];
		memset(admit,0,sizeof(admit));
		for(int i=0;i<m;++i)//m个研究生院的招生名额
			cin>>quota[i];
		for(int i=0;i<n;++i)
		{
			s[i].id=i;//定义id
			cin>>s[i].ge>>s[i].gi;//输入成绩
			for(int j=0;j<k;++j)
				cin>>s[i].school[j];//每个学生选择的k个学校
			s[i].avg=(s[i].ge+s[i].gi)/2;//平均成绩
			s[i].temp=0;//一开始标记初始化为0
		}
		sort(s,s+n,cmp);
		for(int i=1;i<n;++i)
		{
			if(s[i].avg==s[i-1].avg&&s[i].ge==s[i-1].ge)//如果两个学生平均成绩和ge成绩均相等,标记第二个学生
				s[i].temp=1;
		}
		for(int i=0;i<n;++i)
		{
			if(s[i].temp==0)
				memset(admit,0,sizeof(admit));
			for(int j=0;j<k;++j)
			{
				int num=s[i].school[j];//学生选择的学校
				if(quota[num]>0)//学校有名额
				{
					quota[num]--;
					ans[num].push_back(s[i].id);//接受该学生,并标记学号
					if(quota[num]==0)//学校已招满,没有名额了,但是如果遇到平均成绩和ge成绩均相等的同学,同样接收,所以标记一下
						admit[num]=1;
					break;//学生去了目标学校,直接退出for循环
				}
				else if(s[i].temp==1&&admit[num]==1)//遇到平均成绩和ge成绩均相等的同学
				{
					ans[num].push_back(s[i].id);
					break;
				}
			}
		}
		//排好序输出
		for(int i=0;i<m;++i)
		{
			sort(ans[i].begin(),ans[i].end());
			vector<int>::iterator it;
			if(ans[i].empty())//学校无学生
			{
				cout<<endl;
				continue;
			}
			it=ans[i].begin();
			cout<<*it++;
			while(it!=ans[i].end())
				cout<<" "<<*it++;
			cout<<endl;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值