杭电1009


 
 
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
   
   
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
   
   
13.333 31.500
 
贪心算法
#include<iostream>
#include<algorithm>
#include<iomanip>
using namespace std;
const double max=1010;
struct inf
{
    double J,F,ratio;
};

struct inf a[1010];

bool cmp1(struct inf p1,struct inf p2)
{
    if(p1.ratio<=p2.ratio)
        return 1;
    else return 0;
}

int main()
{
    int i;
    double M,N,sumJ,sumF;
    while(cin>>M>>N)
    {
        if(M==-1&&N==-1)
            return 0;
        for(i=0;i<N;i++)
        {
            cin>>a[i].J>>a[i].F;
            a[i].ratio=a[i].F/a[i].J;
        }

        sort(a,a+(int)N,cmp1);

        sumJ=0;sumF=0;i=0;

        while(sumF<M&&i<N)
        {
            sumJ=sumJ+a[i].J;
            sumF=sumF+a[i].F;
            i++;
        }
        if(sumF<M&&i>=N)
        {
            cout<<setiosflags(ios::fixed)<<setprecision(3)<<sumJ<<endl;
            continue;
        }
        i--;
        sumF=sumF-a[i].F;
        sumJ=sumJ-a[i].J;
        sumJ=sumJ+(M-sumF)/a[i].F*a[i].J;
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<sumJ<<endl;
    }
    return 0;
}
点击打开题目链接
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值