杭电1009题

1.题目:FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 
 
Sample Output
     
     
13.333 31.500
 
2.自己的代码
#include<stdio.h>
struct room{
 int bean;  
 int cf;    
 double ag;  
};
int main()
{
 int m,n,i,j;  
 double hbean;    
    struct room rooms[1001],t;
 scanf("%d%d",&m,&n);
 while(m!=-1&&n!=-1)
 {
     hbean=0;
     for(i=0;i<n;i++)
  {
   scanf("%d%d",&rooms[i].bean,&rooms[i].cf);
   rooms[i].ag=rooms[i].bean*1.0/rooms[i].cf;
  }
  for(i=0;i<n;i++)       
    for(j=i+1;j<n;j++)
     if(rooms[i].ag<rooms[j].ag)
     {
                 t=rooms[i];
                 rooms[i]=rooms[j];
                 rooms[j]=t;
     }
 for(i=0;i<n;i++)
  if(m>rooms[i].cf)
  { m-=rooms[i].cf;
      hbean+=rooms[i].bean;
  }
  else {
   hbean+=rooms[i].ag*m;
   break;
  }
     printf("%.3lf\n",hbean);
     scanf("%d%d",&m,&n);
 }
 return 0;
}
3.经大牛修改后更完美的代码
#include<algorithm>
#include<stdio.h>
using namespace std;
const int maxn=1010;
struct node
{
    double java,food,jpf;
} room[maxn];
bool cmp(node a,node b)
{
    return a.jpf>b.jpf;
}
int main()
{
    int n,m,i;
    double ans;
    while(scanf("%d%d",&m,&n))
    {
        if(n==-1&&m==-1)
            break;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&room[i].java,&room[i].food);
            room[i].jpf=room[i].java/room[i].food;
        }
        sort(room,room+n,cmp);
        ans=0;
        for(i=0;i<n;i++)
        {
            if(m>room[i].food)
                ans+=room[i].java,m-=room[i].food;
            else
            {
                ans+=m*room[i].jpf;
                break;
            }
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}
4.归纳总结
1.第一次提交时没有ac,经过大牛指点发现时数组给的是rooms[300],给小了,把数组大小改正后就ac掉了。由此以后做题要注意把数组给大点,
避免数据过多时无法通过。
2.大牛用的algorithm是c++中的头文件,用了里面的sort函数来排序,可以避免自己写排序函数时出现不必要的错误,提高了编程效率。
3.大牛的多组数据输入格式比我的完美,可以借鉴。
4.大牛在开头用的const int maxn=1010;能很方便的更改数组大小。
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值