POJ 3210 : Coins

POJ 3210 : Coins

Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 7001 Accepted: 4616

Description

Snoopy has three coins. One day he tossed them on a table then and tried to flip some of them so that they had either all heads or all tails facing up. After several attempts, he found that regardless of the initial configuration of the coins, he could always achieve the goal by doing exactly two flippings, under the condition that only one coin could be flipped each time and a coin could be flipped more than once. He also noticed that he could never succeed with less than two flippings.

Snoopy then wondered, if he had n coins, was there a minimum number x such that he could do exactly x flippings to satisfy his requirements?

Input

The input contains multiple test cases. Each test case consists of a single positive integer n (n < 10,000) on a separate line. A zero indicates the end of input and should not be processed.

Output

For each test case output a single line containing your answer without leading or trailing spaces. If the answer does not exist, output “No Solution!”

Sample Input

2
3
0

Sample Output

No Solution!
2

题意我觉得很难理解,意思是n个硬币,无论是怎么摆的(正面或是反面),能否找到一个最小值x,使得这n个硬币,通过x次翻转,必能到达全正或是全反的状态。能,则输出x的值。不能,则输出“No Solution!”

分情况讨论:

如果n是一个偶数:
假设向上的数量为偶数,则向下的数量也一定为偶数,所以这个最小值x也一定是偶数。
假设向上的数量是奇数,则向下的数量也是奇数,这个最小值x一定得是奇数。
此时。得到的x在两种情况中互相矛盾,所以偶数的话,要输出“No Solution!”

如果n是一个奇数:
其实n是一个奇数的话,只有一种情况了,向上的数量是m,向下的数量是n-m,两者一定一个奇数,一个偶数。此时向上即向下,向下即向上。
此时会发现偶数次翻转即可完成任务,只需将状态不同的两种硬币中,为偶数的数量的那一堆翻转即可,此时两堆硬币已经达到了同上或是同下,这时,多出来的反转次数,只需对一个硬币来回翻转,因为是偶数次,所以不影响最后状态了。
那么这个x最小是多少?
假设n个硬币,1个向上,n-1个向下。根据上面所述,这时需要n-1次翻转,这时是满足所有情况的最小值了。

代码:

#include<iostream>
using namespace std;

int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0)
            break;

        if(n%2)
        {
            cout<<n-1<<endl;
        }
        else
        {
            cout<<"No Solution!"<<endl;
        }
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值