POJ 1045:Bode Plot

Bode Plot
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13392 Accepted: 8462

Description

Consider the AC circuit below. We will assume that the circuit is in steady-state. Thus, the voltage at nodes 1 and 2 are given by v 1 = V S cos wt and v 2 = V Rcos ( wt +  q ) where V S is the voltage of the source, w is the frequency (in radians per second), and t is time. V R is the magnitude of the voltage drop across the resistor, and  q is its phase. 

You are to write a program to determine V R for different values of  w. You will need two laws of electricity to solve this problem. The first is Ohm's Law, which states v 2 = iR where i is the current in the circuit, oriented clockwise. The second is i = C d/dt (v 1-v 2) which relates the current to the voltage on either side of the capacitor. "d/dt"indicates the derivative with respect to t. 

Input

The input will consist of one or more lines. The first line contains three real numbers and a non-negative integer. The real numbers are V S, R, and C, in that order. The integer, n, is the number of test cases. The following n lines of the input will have one real number per line. Each of these numbers is the angular frequency,  w

Output

For each angular frequency in the input you are to output its corresponding V R on a single line. Each V R value output should be rounded to three digits after the decimal point.

Sample Input

1.0 1.0 1.0 9
0.01
0.031623
0.1
0.31623
1.0
3.1623
10.0
31.623
100.0

Sample Output

0.010
0.032
0.100
0.302
0.707
0.953
0.995
1.000
1.000

水题,公式推导。话说真不能再总纠结这水题了,越做越水了现在。

 v1 = VS

v2 = VRcos (wt + q ) 

 v2 = iR

C=d/dt (v1-v2) 即(v1-v2) 对t求导

已知Vs,C,R,w,求 VR。因为任意的t,等式都成立,所以对t取特殊值,解方程即可。

代码:

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

int main()
{
	double Vs,R,C,w;
	int n,i;
	cin>>Vs>>R>>C>>n;

	for(i=1;i<=n;i++)
	{
		cin>>w;
		printf("%.3f",sqrt(1.0/(1+C*C*w*w*R*R))*C*w*R*Vs);
		cout<<endl;
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值