POJ 1011:Sticks 经典搜索

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 128734 Accepted: 30173

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

题意是给你N根木棒,这些木棒是由若干个长度相同的木棒cut来的,原来的木棒长度不知道了,原来有多少根不知道了,需要你去求最小的可能的木棒长度。

这题是POJ2362的加强版,从棒子的最大长度开始搜起,一直到sum。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

int num_s,sum,temp;
int stick[70];
bool visit[70];

bool dfs(int num,int length,int stick_st,int * stick,bool *visit)
{
	if(num==(sum/temp))
		return true;
	int i;
	int sample=-1;
	for(i=stick_st;i<=num_s;i++)
	{
		if(visit[i]||stick[i]==sample)continue;//剪枝3,之前不行的木棒,再次碰到相同长度的,直接cut。

		visit[i]=true;
		if(length+stick[i]<temp)
		{
			if(dfs(num,length+stick[i],i+1,stick,visit))
			{
				return true;
			}
			else
			{
				sample=stick[i];
			}
		}
		else if(length+stick[i]==temp)
		{
			if(dfs(num+1,0,1,stick,visit))
			{
				return true;
			}
			else
			{
				sample=stick[i];
			}
		}
		visit[i]=false;
		
		if(length==0)//剪枝4,给你最好的条件你都不作为,那么接下来这跟木棒是不可能有任何作为的,cut。
			break;
	}
	return false;
}

bool cmp(const int a,const int b)
{
	return a>b;
}

int main()
{
	int i;
	while(1)
	{
		scanf("%d",&num_s);
		if(num_s==0)
			break;

		sum=0;
		for(i=1;i<=num_s;i++)
		{
			scanf("%d",&stick[i]);
			visit[i]=false;
			sum += stick[i];
		}
		sort(stick+1,stick+1+num_s,cmp);

		bool flag=false;
		for(temp=stick[1];temp<=sum/2;temp++)//剪枝1,最多就实验到sum/2,如果sum/2都不行的话,就说明只能是sum了。因为要把木棍分成几个啊,都大于sum的一半了肯定分不了了啊
		{
			if(sum%temp==0)//剪枝2
			{
				if(dfs(1,0,1,stick,visit))//第一个数代表要当前完成第几根木棒
					                      //第二个数代表当前已经完成的长度
						                  //第三个数代表木棒从第几个开始找起的
				{
					cout<<temp<<endl;
					flag=true;
					break;
				}
			}
		}
		if(!flag)
			cout<<sum<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值