POJ 1700:Crossing River

45 篇文章 0 订阅

Crossing River
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12537 Accepted: 4766

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

题意是一群人要过河,船只有一个,且船上只能乘坐两个人。每个人划船都有一个自己的速度,两个人划船的话,船的速度取决于较慢的那个人划船的速度。问这些人过河移动需要的最短时间。

递推。一二三人过河方式只有一种。拿四个人举例,a,b,c,d。划船所需时间依次增大。

有两种方式:

第一种:

ad过河。

a回来。

ac过河。

a回来。

ab过河。


第二种:

ab过河。

a回来。

cd过河。

b回来。

ab过河。


所以会发现对于多个人数来说,要么是最大的两个一起过(先把速度小的一个运过去),要么就是一个一个过。

代码:

#pragma warning(disable:4996)
#include <iostream>  
#include <algorithm>
#include <cstring>
#include <vector>  
#include <string>  
#include <cmath>
#include <queue>
#include <map>
using namespace std;

typedef unsigned long long ll;
const int maxn = 5005;

int n;
int dp[maxn], val[maxn];

void input()
{
	int i;
	scanf("%d", &n);

	for (i = 1; i <= n; i++)
	{
		scanf("%d", val + i);
	}
}

int dfs()
{
	int i;
	dp[1] = val[1];
	dp[2] = val[2];
	dp[3] = val[1] + val[2] + val[3];
	for (i = 4; i <= n; i++)
	{
		dp[i] = val[i] + val[1] + min(dp[i - 1], 2 * val[2] + dp[i - 2]);
	}
	return dp[n];
}

void solve()
{
	sort(val + 1, val + n + 1);
	printf("%d\n", dfs());
}

int main()
{
	//freopen("i.txt", "r", stdin);
	//freopen("o.txt", "w", stdout);

	int t;
	scanf("%d", &t);
	while (t--)
	{
		input();
		solve();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值