POJ 1458 Common Subsequence

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35595 Accepted: 14185

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
 
-----------------------------------------------------------------------------
状态转移方程:
if(st1[i]==st2[j])
res[i+1][j+1]=res[i][j]+1;
else
res[i+1][j+1]= res[i][j+1]>res[i+1][j] ?res[i][j+1]:res[i+1][j] ;
res[i][j]表示字符串字串st1[0-i],st2[0-j]的公共子序列长度。
 
 
#include<stdio.h>
#include<stdlib.h> //最长公共子序列,别的不说了
#include<string.h>
#define MAX 1001    //唯一注意的是数组的大小
#define  Max(x,y)  (x)>(y)?(x):(y)
int main()
{
	char string1[MAX];
	char string2[MAX];
	//char string1a[26];
	//char string1b[26];
	int string[MAX][MAX];
	int max1,max2,i,j;
	
	while(scanf("%s%s",string1,string2)!=EOF)
	{
	memset(string, 0, sizeof(string));
	//gets(string1);
	//gets(string2);
	//memset(c,0,sizeof(string));
	max1=strlen(string1);
	max2=strlen(string2);
	
	
	for(i=1;i<=max1;i++)
	  for(j=1;j<=max2;j++)
	  {
	  	if(string1[i-1]==string2[j-1])
	  	  {
	  	  	string[i][j]=string[i-1][j-1]+1;//关键1
	  	  }
	  	else
	  	    string[i][j] = Max(string[i][j-1], string[i-1][j]);//关键2
	  }
	
	
	printf("%d\n",string[max1][max2]);
   }
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值